VLAny přes Zyxel manage switch

Návody a problémy s konfigurací.
ludvik
Příspěvky: 4162
Registrován: 7 years ago

Re: VLAny přes Zyxel manage switch

Příspěvekod ludvik » 2 weeks ago

Tvrdí, že mu to nejde i bez toho dhcp ... tímto směrem jsem se ho už snažil nasměrovat.

ještě poslední věc: dej sem výpisy ze submenu Monitor ohledně VLAN.

A jako tonoucí chytající se stébla - vyzkoušej vyšší čísla VLAN, třímístné a čtyřmístné. Kdysi jsem si s tím naběhl u Allied Telesyn. Je to blbost ... ale co víme?
1 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.

iTomB
Příspěvky: 864
Registrován: 12 years ago

Příspěvekod iTomB » 2 weeks ago

Nastav si sit, hod si na ten port mikrotika s pevnou IP, pust si ping a zkousej prenastavovat switch.
0 x

Xardas123
Příspěvky: 22
Registrován: 4 months ago

Příspěvekod Xardas123 » 2 weeks ago

svestka píše:píšeš ... "Na eth5 v RB mám nastaveno VLANů několik + dhcp server přímo na eth5".
A máš v RB puštěný DHCP na eth5.30 apod?
Už mi přijde že je spíš problém v blbě nastaveném MK.


Když místo switche připojím svůj druhý RB dostane přes eth5 adresu, stejně tak i přes VLANY, které tam mám. jedině že by v RB bylo něco "blbě/jinak" co druhému Mikrotiku nevadí, ale switchy jo.
0 x

Xardas123
Příspěvky: 22
Registrován: 4 months ago

Příspěvekod Xardas123 » 2 weeks ago

iTomB píše:Nastav si sit, hod si na ten port mikrotika s pevnou IP, pust si ping a zkousej prenastavovat switch.


Pokus omyl jsem zkusil snad jako první. Měl jsem tam PC s pevnou ip, stejně tak jsem to zkusil znovu teď nastavit si pevnou IP z podsítě kde je switch i RB. Nedostanu se nikam dál. pingy nikam nejdou, tracert nikam nejde. prostě přes porty kde mám zmíněný vlan30 untagged se nedostanu nikam, přes to že mám ip ze stejné podsítě, masku, dns nadefinováno ručně.
0 x

Xardas123
Příspěvky: 22
Registrován: 4 months ago

Příspěvekod Xardas123 » 2 weeks ago

ludvik píše:Tvrdí, že mu to nejde i bez toho dhcp ... tímto směrem jsem se ho už snažil nasměrovat.

ještě poslední věc: dej sem výpisy ze submenu Monitor ohledně VLAN.

A jako tonoucí chytající se stébla - vyzkoušej vyšší čísla VLAN, třímístné a čtyřmístné. Kdysi jsem si s tím naběhl u Allied Telesyn. Je to blbost ... ale co víme?


Zkusil jsme to teď přenastavit na VLAN 300. Stejně nic. Mrtvo.
Nevím jestli vím co přesně chceš. Tuto ?

Kód: Vybrat vše

Flags: X - disabled, R - running
 #   NAME                                    MTU ARP             VLAN-ID INTERFACE                               
 0 R vlan10_SET                             1500 enabled              10 ether5_LAN2                             
 1 R vlan20_APFree                          1500 enabled              20 ether5_LAN2                             
 2 R vlan30_LAN                             1500 enabled             300 ether5_LAN2                             

Kód: Vybrat vše

/interface vlan
add interface=ether5_LAN2 name=vlan10_SET vlan-id=10
add interface=ether5_LAN2 name=vlan20_APFree vlan-id=20
add interface=ether5_LAN2 name=vlan30_LAN vlan-id=300
0 x

ludvik
Příspěvky: 4162
Registrován: 7 years ago

Příspěvekod ludvik » 2 weeks ago

Copak v mikrotiku je nějaký monitor VLAN? Je v zyxelu ...
0 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.

Xardas123
Příspěvky: 22
Registrován: 4 months ago

Příspěvekod Xardas123 » 2 weeks ago

Záhada vyřešena. Už vím proč to nejde. Předešlému switchy EdgeCore to nevadilo, chvilku jsem tu měl dokonce Cisco tomu to taky nevadilo, ale Zyxel kvůli tomu nejede.

Jde o to že v portech, které jsou nastaveny:
PVID: 1
Accept frame type: ALL
Ingress Check: Disable
VLAN Trunk: Disable
VLAN ID: 1 - Untagged
VLAN ID: 30 - Executed

Což je podsíť z mého eth5 mám zapojený i druhý RB, kde byli též nastavené VLANY, ale nebyli nastaveny na tagged ve switchy. Jakmile jsem tento RB odpojil Vlany začali jít. Tudíž jsem na portu kde je tento RB dal tagged zbylé 2 vlany. Na portu 1 kde je první RB jsem taky otagoval zbylé dva VLANY a vše jede jak má.

Omlouvám se a všem moc děkuji za rady a ochotu.
0 x

Čavli
Příspěvky: 7
Registrován: 1 month ago

Příspěvekod Čavli » 2 weeks ago

To tam máš ale celkem bordel. K čemu to tak je, když ani předchozí switche na to nebyly nastaveny?
Základ když hledám problém je vše co není třeba odpojit.
0 x

Xardas123
Příspěvky: 22
Registrován: 4 months ago

Příspěvekod Xardas123 » 2 weeks ago

Čavli píše:To tam máš ale celkem bordel. K čemu to tak je, když ani předchozí switche na to nebyly nastaveny?
Základ když hledám problém je vše co není třeba odpojit.


Žádný bordel.. Switche co tam byli před tím nefungovali správně. Edgecore se pořád resetoval do defaultu. Jakmile jsem nastavil víc než jeden vlan sekl se, rebootnul a byl v defaltu. Cisco tam bylo jen přechodně na chvilku když edgecora odešla úplně do kopru a pak přišel Zyxel. Před switchema byli RB propojeny přímo takže Vlany byly používány a byli potřeba. Jen by mě ani ve snu nenapadlo že to bude u zyxelu takhle zlobit když je nenastavím.

Chtěl jsem je používat všechny, ale začal jsme nastavením prvního vlanu, protože jsem si nebyl jistý konfigurací a ten nešel nijak rozchodit jak již víte. Je možné že kdybych to tam nabouchal vše fungovalo by to hned na první dobrou. Vím pro příště na co si dát pozor.
0 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 6 hostů