2 konekty jeden hlavny a jeden zalozny

Návody a problémy s konfigurací.
pavelsiman
Příspěvky: 213
Registrován: 1 year ago

2 konekty jeden hlavny a jeden zalozny

Příspěvekod pavelsiman » 3 months ago

zdravim . Nasledovna konfiguracia : RB2011 : ETH 1 optika 100mb ETH 2: O2 30mb zaloha . potrebujem aby sa v prípade výpadku preplo na zálohu . za O2 mam hned mikrotik 951 a nan tunel ale pokial optika vypadne na tu RB2011 sa nedostanem nejake rady ako jednoducho na zálohu
0 x

pedro4444
Příspěvky: 657
Registrován: 7 years ago

Příspěvekod pedro4444 » 3 months ago

pavelsiman píše:zdravim . Nasledovna konfiguracia : RB2011 : ETH 1 optika 100mb ETH 2: O2 30mb zaloha . potrebujem aby sa v prípade výpadku preplo na zálohu . za O2 mam hned mikrotik 951 a nan tunel ale pokial optika vypadne na tu RB2011 sa nedostanem nejake rady ako jednoducho na zálohu


ak nemas verejnu od o2 ako sa tam chces dostat?
a druha vec treba napisat aj odkial sa napajas ak by si sa napajal kde je verejna mozes dat z toho backupu aby ti vytacalo vpn na tvoj domaci a tym pado msa tam vies dostat...
0 x

Uživatelský avatar
Myghael
Příspěvky: 1038
Registrován: 6 years ago

Příspěvekod Myghael » 3 months ago

Jo, použij hledání. Toto se tu řešilo už ani nevím kolikrát, naposledy nedávno.
0 x
Si vis pacem, para bellum.

MikroTik, UBNT, Cisco, TP-Link... rozhoduje vhodnost toho či onoho pro konkrétní použití, ne jaké logo nalepili v Číně na krabici. Na tomto fóru vystupuji jen a pouze sám za sebe.

pavelsiman
Příspěvky: 213
Registrován: 1 year ago

Příspěvekod pavelsiman » 3 months ago

No riešilo ale nikdy poriadne nedoriesilo. Keď vypadne optika kde je verejná tak sa snažím dostať cez VPN ktorá sa vytáča z rb951 ku mne domov. Keď je optika funkčná tak sa tam dostanem aj cez to rb 951 ale pokiaľ vypadne optika tak sa tam nemám ako dostať
0 x

Noxus28
Příspěvky: 291
Registrován: 6 years ago

Příspěvekod Noxus28 » 3 months ago

Keď nie je verejka tak z 951 vytoč tunel niekam kde verejku máš, najlepšie aj z optiky vytoč tunel na to isté miesto, na tom verejnom daj všetky tunely do bridge a domov sa dostaneš či ti bude fungovať optika alebo nie, stačí dobre nastavený statický routing...
Ostatok je už len obyčajné zadanie dvoch default route s check gateway, prípadne iné riešenia ktoré sú tu rozvinuté hádam v každom 10tom témate
1 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓

pedro4444
Příspěvky: 657
Registrován: 7 years ago

Příspěvekod pedro4444 » 3 months ago

Noxus28 píše:Keď nie je verejka tak z 951 vytoč tunel niekam kde verejku máš, najlepšie aj z optiky vytoč tunel na to isté miesto, na tom verejnom daj všetky tunely do bridge a domov sa dostaneš či ti bude fungovať optika alebo nie, stačí dobre nastavený statický routing...
Ostatok je už len obyčajné zadanie dvoch default route s check gateway, prípadne iné riešenia ktoré sú tu rozvinuté hádam v každom 10tom témate


presne tak...
0 x

pavelsiman
Příspěvky: 213
Registrován: 1 year ago

Příspěvekod pavelsiman » 3 months ago

Dnes som to nejako poriesil uz to krasne prepína tu je výpis s testu :

/ip route
add check-gateway=ping distance=1 gateway=8.8.4.4 target-scope=10
add distance=3 gateway=192.168.51.1
add distance=1 dst-address=8.8.4.4/32 gateway=192.168.25.1 scope=10
add distance=1 dst-address=8.8.8.8/32 gateway=192.168.25.1 scope=10


lenze pinguje mi to iba jednu ip ked pridam podla manualu napr:

add gateway=8.8.8.8,8.8.4.4 check-gateway=ping tak to uz neprepne . potreboval by som okrem 8.8.8.8 pingovat este aj moju branu a aby to pri výpadku oboch preplo
0 x

Noxus28
Příspěvky: 291
Registrován: 6 years ago

Příspěvekod Noxus28 » 3 months ago

a čo takto?

Kód: Vybrat vše

ip route add dst-address=0.0.0.0/0 gateway="optik GW IP" check-gateway=ping distance=1 comment="optika"
ip route add dst-address=0.0.0.0/0 gateway="O2 GW IP" check-gateway=ping distance=2 comment="O2"
ip route add dst-address=8.8.8.8 gateway="optik GW IP"  comment="kontrola optik"

v tools netwatch

Kód: Vybrat vše

/tool netwatch
add down-script="/ip route disable [/ip route find comment=\"optika\"]" host=8.8.8.8 up-script=\
    "/ip route enable [/ip route find comment=\"optika\"]"


routa sa ti vypne pri strate pingu na IP brány, + netwatch ti ju vypne alebo zapne ak sa dopingá rsp nedopingá na 8.8.8.8 cez bránu na optike. Pozor ak máš cez 8.8.8.8 aj trebárs DNS
1 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓

pavelsiman
Příspěvky: 213
Registrován: 1 year ago

Příspěvekod pavelsiman » 3 months ago

no ono to tak ako chcem nefunguje lebo ked sa to prepne na zalohu tak netwatch krasne pinguje cez záloznú konektivitu
0 x

Noxus28
Příspěvky: 291
Registrován: 6 years ago

Příspěvekod Noxus28 » 3 months ago

jj tak to bude ešte treba ukončiť tú 8.8.8.8

Kód: Vybrat vše

ip route add gateway=127.0.0.1 distance=100 dst-address=8.8.8.8/32 type=prohibit

0 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓

pavelsiman
Příspěvky: 213
Registrován: 1 year ago

Příspěvekod pavelsiman » 3 months ago

Ja by som potreboval ping 8.8.8.8 a aj bránu a potrebujem aby to bolo ideálne tak ze sa to aj prepne naspäť keď je konekt funkčný
0 x

Noxus28
Příspěvky: 291
Registrován: 6 years ago

Příspěvekod Noxus28 » 3 months ago

0 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host