Vytvorenie VPN

Návody a problémy s konfigurací.
minos
Příspěvky: 9
Registrován: 1 month ago

Vytvorenie VPN

Příspěvekod minos » 1 month ago

Dobrý deň, práve začínam s mikrotikom a nemám vpodstate žiadne skúsenosti.
Mám router RB750Gr3. Internet v budove je riešený nasledovne: v budove je statická verejna ip a sú pred mojím RB750Gr3 ešte dva routre ku ktorým nemám prístup. Správca budovy mi vyhradil zopár portov aby som sa z verejnej ip mohol pripojiť k zariadeniam. Ja som si cez NAT (dstnat) nastavil dané zariadenia. Toto funguje bez problémov. Z vonku sa vpohode pripojím na moje zariadenia. Avšak rozmýšľal som vytvoriť na mojom routry VPN server kde by som sa najskôr musel z vonku pripojiť na moju vpn a až potom by som mal prístup k mojím zariadeniam. Ako to mám nastaviť? Ďakujem.
0 x

pgb
Příspěvky: 600
Registrován: 2 years ago

Příspěvekod pgb » 1 month ago

Díky tomu že máš přesměrované porty nemůžeš použít ipsec a jeho deriváty. Koukni se jak nastavit OpenVPN.
0 x

minos
Příspěvky: 9
Registrován: 1 month ago

Příspěvekod minos » 1 month ago

Ďakujem, bolo by možne poslať návod najlepsie v cz/sk na vytvotenie OpenVPN na mikrotik s presmerovanymi portami?
0 x

pgb
Příspěvky: 600
Registrován: 2 years ago

Příspěvekod pgb » 1 month ago

Google a Mikrotik wiki
0 x

mirek.k
Příspěvky: 716
Registrován: 11 years ago

Příspěvekod mirek.k » 1 month ago

OpenVPN je dost složité. Já bych doporučil SSTP.
1 x

Rosak
Příspěvky: 190
Registrován: 6 years ago

Příspěvekod Rosak » 1 month ago

Také jsem se před pár roky přesvědčil, že je konfigurace OpenVPN složitá a postavil si VPN na SSTP. Před pár týdny jsem se z nutnosti umět připojit i zařízení od Apple podíval na konfiguraci OpenVPN a sám sobě jsem se vysmál. Je to jednoduché, na Youtube je dokonce několik velice přehledných návodů.
0 x

zemji
Příspěvky: 21
Registrován: 12 years ago

Příspěvekod zemji » 1 month ago

Krásně je to popsané třeba zde: https://blog.svaskem.cz/openvpn-na-mikrotiku/
1 x

Václav Šulc
Příspěvky: 1
Registrován: 1 month ago

Příspěvekod Václav Šulc » 1 month ago

Dnes jsem doplnil nové informace do článku a ještě jsem ho trochu více zpřehlednil. Snad bude užitečný:
https://blog.svaskem.cz/openvpn-na-mikrotiku/
0 x

emel
Příspěvky: 84
Registrován: 2 years ago

Příspěvekod emel » 1 month ago

Ak by si to ešte potreboval, môžem ti poslať konfig OpenVPN na MikroTiku
0 x

minos
Příspěvky: 9
Registrován: 1 month ago

Příspěvekod minos » 3 weeks ago

Ďakujem, stále sa mi to nepodarilo rozchodiť. Postupoval som podľa návodu, všetko prebehne, len OpenVPN sa nedokáže pripojiť.
Log z OpenVPN:

Kód: Vybrat vše

Wed May 29 15:08:14 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]8x.xxx.xxx.xx:7003
Wed May 29 15:08:14 2019 Socket Buffers: R=[65536->65536] S=[65536->65536]
Wed May 29 15:08:14 2019 Attempting to establish TCP connection with [AF_INET]8x.xxx.xxx.xx:7003 [nonblock]
Wed May 29 15:08:14 2019 MANAGEMENT: >STATE:1559135294,TCP_CONNECT,,,,,,
Wed May 29 15:10:14 2019 TCP: connect to [AF_INET]8x.xxx.xxx.xx:7003 failed: Unknown error


Postupoval som nasledovne:

Kód: Vybrat vše

/certificate add name=CA-ITLES country="SK" state="Slovak Republic" organization="IT LES" unit="H" common-name=CA-ITLES key-usage=key-cert-sign,crl-sign days-valid=3650 key-size=2048
/certificate sign CA-ITLES ca-crl-host=8x.xxx.xxx.xxx:7003 name=CA-ITLES
/certificate export-certificate CA-ITLES
/certificate set CA-ITLES trusted=yes
/certificate add name=OPENVPN-SERVER-tpl country="SK" state="Slovak Republic" organization="IT LES" unit="H" common-name="vpn.itles.cz" key-usage=digital-signature,key-encipherment,tls-server days-valid=3650 key-size=2048
/certificate sign OPENVPN-SERVER ca=CA-ITLES name=OPENVPN-SERVER
/certificate set OPENVPN-SERVER trusted=yes
/certificate add name=client-tpl country="SK" state="SK" organization="IT LES" locality="Bratislava" common-name="client" days-valid=3650 key-size=2048 key-usage=tls-client
/certificate add name=milan copy-from="client-tpl" common-name="milan"
/certificate sign milan ca="CA-ITLES" name="milan"
/certificate export-certificate milan export-passphrase=Heslo123
/certificate set milan trusted=yes
/ip firewall filter add action=accept chain=input protocol=tcp dst-port=1194   
/ip firewall filter add chain=input src-address 10.20.0.0/24 action=accept
/ip firewall filter add chain=forward src-address 10.20.0.0/24 action=accept   
add action=dst-nat chain=dstnat dst-address=192.168.1.34 dst-port=7003 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.88.1 to-ports=1194


Ide o to, že pred mojím routrom RB750Gr3 sú ešte dva routre ku ktorým nemám prístup. Správca budovy mi vyhradil zopár portov aby som sa z verejnej ip mohol pripojiť k zariadeniam. Ja som si cez NAT (dstnat) nastavil presmerovanie z 7003 na vnútorny port 1194. Kde robím chybu? Ďakujem.
0 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: TheZIGI a 2 hosti