IPTV přes WMM nebo NV2 (MikroTik)

Problematika videa na IP sítích.
Zsir
Příspěvky: 69
Registrován: 3 years ago

IPTV přes WMM nebo NV2 (MikroTik)

Příspěvekod Zsir » 1 year ago

Ahoj,

Poskytujeme IPTV od kuki a potřeboval bych poradit kde dělám chybu.

Zařízení: SXT to omnitik.

Paket od Netboxu je označet DSCP 32 (CS4), který na LAN sítí řídíme v queue tree bezproblemu a chtěli by jsme to testovat na 5 GHz.

-Na AP i clientovi je zapnute WMM.
-bridge firewall je zaplej na clientovi i AP.
-paket TV nastavim na prioritu 5.
-ostatní je best-effort s hodnotou 0.

Problém nastává, když zkusím bandwidth z více klientu, tak se šířka pásma rozděluje rovnoměrně (diky queue typu - sfq). Ale rozděluje se rovnoměrně i pro televizi a přitom jsem předpokládal, že když máji pakety IPTV vyšší prioritu, že TV dostane 20 MBps (který má omezeno) a ostatní klienti se budou rovnoměrně dělit šířkou pásma.

Mangle
/ip firewall mangle add action=set-priority new-priority=
5 dscp=32 comment=IPTV chain=prerouting

V logu vidím přesně že to funguje, ale nefunguje to tak jsem si představoval ...:-( u ICMP prioritizace mi to funguje správně.

Jediná možnost jak to funguje je, že nastavím set priority zapnu passthrougth a podto dám pravidlo mark-packet a v QT tomu dám prioritu 1 a celkově si řídím pásmo.

-Dá se nějak udělat, aby TV měla minimální garanci aspoň 15Mbps bez QT ?
-Nebo mi WMM nefunguje jak má? protože pokud si rozděluje pásmo rovnoměrně, tak to pak postráda WMM smysl, když rozděluje spravedlivě šířku pásma bez zavislosti na IPTV.

Diky za odpovědi.
Přílohy
oznaceni paketu.png
oznaceni paketu.png (43.33 KiB) Zobrazeno 2029 x
0 x

Dalibor Toman
Příspěvky: 1208
Registrován: 6 years ago

Příspěvekod Dalibor Toman » 1 year ago

podle https://wiki.mikrotik.com/wiki/Manual:Queue#SFQ SFQ nebere v uvahu zadnou prioritu. Takze si to budes muset zrejme nejdrive rozdelit podle priority do 2 proudu sam
0 x

Uživatelský avatar
3com
Příspěvky: 575
Registrován: 8 years ago

Příspěvekod 3com » 1 year ago

Garance 15Mbps pro IPTV přes wifi :joy:
0 x

Zsir
Příspěvky: 69
Registrován: 3 years ago

Příspěvekod Zsir » 1 year ago

Diky vyzkouším.

Bavíme se o vesnicích, kde pásmo 5 GHz není vůbec zarušené a šlo by používát i 40 MHz.

Na kopcích nebo v brně jsou lidi rádi za internet, natož TV přes Wi-fi :)
0 x

Zsir
Příspěvky: 69
Registrován: 3 years ago

Příspěvekod Zsir » 1 year ago

-Zvlaštní je, že na protokolu NV2 vše funguje jak má. Dokáže prioritizovat provoz, dokáže prioritizovat ITPV.

-Proč nefunguje WMM na 802.11 protokolu? Přitom nastavení vše by mělo být stejný. Jediný rozdíl vidím v tom, že u NV2 je priorita 1 a 2 < 0, jinak je to prakticky stejné.

Nevíte někdo proč WMM na 802.11 nefunguje? i když priorita je nastavena a WMM na AP i klientovi zapnuto?

Navíc při zapnutí WMM je při přenosu 120 Mbps naměřen bandwidth test 25 Mbps. Ale když disabluju pravidla v Mangle, tak se vše vrátí do normálů rychlost.

Přitom data vidim jak tečou spravně v každém pravidle. Fakt už nevim. Zkoušel jsem to i že není nakonfigurovanej bridge ale jen IP pro jednotlivá rozhraní. Nic. Jak kdyby WMM jen zpomalilo rychlost.

IP Firewall enable
Mangle příkaz
/ip firewall mangle add action=set-priority priority=5 protocol=tcp chain=prerouting
0 x


Zpět na „IPTV“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 3 hosti