CRS328-24P-4S+RM 1G->100M problém

Problematika MikroTik RouterBoard hardware
Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

CRS328-24P-4S+RM 1G->100M problém

Příspěvekod Petr Bačina » 1 year ago

Asi dělám něco špatně nebo nevím. Můžete mi poradit proč celá řada CRS/CSS 326/328 má problém s přechodem 1G na 100Mb? Problém se projevuje následovně.
Uplink doma v síti do RB850 pomocí 1Gb ethernetu. Pokud připojím počítač 1Gb, tak není problém tahat co dá domácí linka 100+Mb. Jenže pokud počítač omezím na 100Mb (kabelem, routerem, PoE injektorem, přes drivery), spadne rychlost stahování z internetu na cca 30-50Mb a kolísá. Zkusím místo z netu stáhnout film z domácí NASky a normálně dostanu plných 100Mb. Takže problém při komunikaci přes router do internetu. Nepomáhají různé kombinace Flow controlu, nic. Jakmile je tam prostě 1Gb->100Mb tak je to v háji. Ale jen do netu. V domácí síti je to OK.
Jenže pak nahradím CRS328 případně CSS326 za CRS125 nebo blbýho TPlinka tak v totožné konfiguraci tahám z netu plných 100Mb.
Jsem blbej já, nebo prostě Mikrotik opět podělal návrh celého switche, použil čipy od Marvellu a tím je celý switch použitelný jen a pouze na 1Gb? A to nepočítám, kdyby někdo chtěl zkoušet 10Gb uplink, to bude úplně to samé.
0 x

KoZLiCeK
Příspěvky: 1175
Registrován: 11 years ago
Bydliště: CZ

Příspěvekod KoZLiCeK » 1 year ago

B je spravne.
0 x

dagus
Příspěvky: 1249
Registrován: 8 years ago

Příspěvekod dagus » 1 year ago

Jo chová se to tak. Ideální jet všechno gigo, což dnes není problém. S 10G portem těžko říct. Jinak nevím, ale zkoušel jsem googlit a příjde mi ten hw hodně podobnej ubnt switchi s poe, ale oni nikde nepíšou switchchip. Možná to bude jen sw problém. 100Mbit porty do 1G switche necpu a ani do rb3011, kde teda flapování portu od verze 6.40.8 nedělá.
0 x

Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 year ago

Tak chtěl jsem ho použít na AP, kde sice většina zařízení je s 1G ethernetem, ale jsou tak i nějaké P2P na RB911 a nechce se mi měnit další RBčka jenom kvůli tomu, že mikrotik není schopný dělat switch pořádně. Přitom i ten blbej TP-Link to zvládá bezproblémů. Navíc bůhví jestli ten switch nemá i další problém krom tohoto.
0 x

Orel005
Příspěvky: 802
Registrován: 8 years ago

Příspěvekod Orel005 » 1 year ago

Stejny problem, jen rozdil je s prechodem 10G na 1G... cca o 30% jede pomaleji, uz jsem zkousel vsechno - reseni neznam.
0 x
http://www.orelsoft.cz / Jediny ISP s HI-TECH servery bez instalacnich poplatku ve stredni Evrope.
Napriklad: 64 jader, 256 GB ram, 4x600 GB SAS 15k, 1 Gbps pripojeni za 14 000,- Kc / mesicne vc. dph.

dagus
Příspěvky: 1249
Registrován: 8 years ago

Příspěvekod dagus » 1 year ago

Řešení HP5500?
0 x

Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 year ago

To právě řešení není... potřebuju pasivní PoE s 24V. Pokud by šlo vše napájet přes af/at, tak se dá vybírat až do aleluja. Takže nezbyde nic jiného než použít Edgeswitch od UBNT. V tomhle se teda Mikrotik vyznamenal. Vypadá to, že cokoliv vymyslí, tak to nějak podělaj a pěkné zařízení degradují na nepoužitelný. Přitom packet buffer to má celkem velký (1,5MB), tak by mu to nemělo dělat problém.
0 x

dagus
Příspěvky: 1249
Registrován: 8 years ago

Příspěvekod dagus » 1 year ago

Však 3011 flapovala a uz to jede. Třeba to odladí, co na to support?
0 x

Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 year ago

Support zatím mlčí. Na stejný problém u CSS326 před několika měsíci ani nereagovali.
0 x

S_a_M
Příspěvky: 419
Registrován: 4 years ago
Bydliště: Protektorat Böhmen und Mähren

Příspěvekod S_a_M » 1 year ago

Takova vec bezi ti to na ROS nebo SOS ?
0 x
Proste trollim :D
Ceragona nikdy vic a CEZ at se jde fakt vycpat ...

Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 year ago

ROS
0 x

dagus
Příspěvky: 1249
Registrován: 8 years ago

Příspěvekod dagus » 1 year ago

To je divny, kdyz na switchos na 100m pise overflow chyby, že na to nereagují
0 x

S_a_M
Příspěvky: 419
Registrován: 4 years ago
Bydliště: Protektorat Böhmen und Mähren

Příspěvekod S_a_M » 1 year ago

A beží ti to jako cistej switch nebo tam máš i jiný fce ??? imho na to by bylo lepší SOS ...
0 x
Proste trollim :D
Ceragona nikdy vic a CEZ at se jde fakt vycpat ...

Uživatelský avatar
hapi
Příspěvky: 12599
Registrován: 12 years ago

Příspěvekod hapi » 1 year ago

co sem tak nějak zkoumal tak se mi zdá že moc nefunguje flow control. Podivný ale je že máme v hlavním racku CRS317 kde jsou 2x10Gbit a 2x1Gbit a není absolutně žádný problém a hned za tim je s 10Gbit uplinkem CRS326 a taky nevidim problém resp. nejsem schopnej ho nasimulovat jako na jiným místě s CRS328 a 10Gbit uplinkem. Takže by mě zajímalo v čem je rozdíl.

všude v6.42.1, flow-control(tx/rx) = auto.
0 x

Petr Bačina
Příspěvky: 1250
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 year ago

S_a_M: jako čistý switch, bez vlan a všehi dalšího. Mezi SwOS a ROS bez rozdílu, to samé.

hapi: Něco takového tam asi bude. Flow control, práce s bufferem... Ale třeba při výměně za CRS125 je vše OK a to může být klidně flow control zakázaný a buffer poloviční.
Nějak se mi nechce věřit že by to bylo problémem přímo v tom switch čipu. Co jsem našel tak stejnou konfiguraci používají i jiní výrobci. Spíš s tím neumí Mikrotik pracovat.

Ještě jsem to reportoval prodejci, kterému se to taky prý nepovedlo nasimulovat. Ale o problému ví i od dalšího kupujícího. Taky to začnou řešit s výrobcem.
0 x


Zpět na „Hardware“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 4 hosti