Jeden forward funguje a jeden ne.

Místo, kde žádná otázka není hloupá.
jval
Příspěvky: 119
Registrován: 11 years ago

Jeden forward funguje a jeden ne.

Příspěvekod jval » 8 months ago

Zdravím, mám na MK nastavený NAT pravidla a jedno mi funguje, ale jiné, které je se liší jen v portu nejede.
Mám například:

Kód: Vybrat vše

chain=dstnat action=dst-nat to-addresses=192.168.1.5 to-ports=3389 protocol=tcp dst-address=xxx dst-address-type=local dst-port=13389

To mi funguje normálně a pak

Kód: Vybrat vše

chain=dstnat action=dst-nat to-addresses=192.168.1.5 to-ports=8080 protocol=tcp dst-address=xxx dst-address-type=local dst-port=18080

A to mi prostě nevalí. Myslel jsem že to koliduje s 8080 na kterém by jel MK, ale v services mám www nastaveno na 8081 a ještě deaktivováno.

Z vnitřní sítě mi samozřejmě 192.168.1.5:8080 jede. Sedí tam Domoticz.

Nevíte někdo kde by mohl být problém?
Děkuji
0 x

mirek.k
Příspěvky: 724
Registrován: 11 years ago

Příspěvekod mirek.k » 8 months ago

Na první pohled to vypadá stejně.
Zkusil bych Torch - tam by se vidělo.
Také counter u pravidla by napověděl.
0 x

jenda.master
Příspěvky: 207
Registrován: 7 years ago

Příspěvekod jenda.master » 8 months ago

už jsem viděl pár večí, který měli problém s redirekcí portu na NATu, zkus si NATovat ten original port 8080
0 x

jval
Příspěvky: 119
Registrován: 11 years ago

Příspěvekod jval » 8 months ago

U pravidla to vypadá, že to tam teče, tak to nejspíš bude problém až na tom domoticz.
Tak zatím děkuji moc.
Přílohy
2018-11-27_131042.jpg
2018-11-27_131042.jpg (19.54 KiB) Zobrazeno 911 x
0 x

johnyboi
Příspěvky: 41
Registrován: 1 year ago

Příspěvekod johnyboi » 8 months ago

default gw na tom dom.. mas spravnou?
0 x

jval
Příspěvky: 119
Registrován: 11 years ago

Příspěvekod jval » 8 months ago

jenda.master píše:už jsem viděl pár večí, který měli problém s redirekcí portu na NATu, zkus si NATovat ten original port 8080

zkusil jsem ale nepomohlo, to spíš vypadá na zakopanýho psa až v tom domoticz
0 x

jval
Příspěvky: 119
Registrován: 11 years ago

Příspěvekod jval » 8 months ago

Vzhledem k tomu, že ve verzi 6.42.3 došlo k zásadnějším změnám, tak jsem se nakonec rozhodl kompletně nastavit router od začátku. Zresetoval jsem tedy nastavení a následně v Quick setu nastavil mode Home AP. Internet atd jede, ale teď se mi nedaří přesměrovat jakýkoliv port.
Mám veřejnou IP.
Zkusil jsem i povypínat default pravidla ve firewallu a stále nic.
V NAT mám nastaveno:

Kód: Vybrat vše

Flags: X - disabled, I - invalid, D - dynamic
 0    ;;; VIVOPC
      chain=dstnat action=dst-nat to-addresses=192.168.1.5 to-ports=3389 protocol=tcp dst-address=xxx dst-port=13389
      log=no log-prefix="" 
 8    ;;; Hairpin - NAT
      chain=srcnat action=masquerade protocol=tcp src-address=192.168.1.0/24 dst-address=192.168.1.5 out-interface=bridge
      dst-port=3389 log=no log-prefix=""
 9    ;;; defconf: masquerade
      chain=srcnat action=masquerade out-interface-list=WAN log=no log-prefix="" ipsec-policy=out,none
 

Pokud se na RDP připojím z vnitřní sítě, tak přes hairpin funguje, pokud se ovšem zkusím připojit zvenku, tak ne. Místo xxx je moje veřejka.
Když koukám na packet counter u daného pravidla, tak počítá jak při pokusu zvenčí, tak i při pokusu zevnitř.
Prosím o radu kam bych měl ještě kouknout.

Děkuji
0 x


Zpět na „Začátečnické témata“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 2 hosti