Jak se dostat na kamerovy system bez verejne IP

Místo, kde žádná otázka není hloupá.
Uživatelský avatar
pcwifi
Příspěvky: 2878
Registrován: 10 years ago
antispam: Ano
Bydliště: Brnensko

Re: Jak se dostat na kamerovy system bez verejne IP

Příspěvekod pcwifi » 4 months ago

me Dahua tak dojebali jeden NVR, ze to jejich P2P uz vubec nejede, kdyz jim pisu ze mi nejde zarizko pridat do toho jejich SW co se pres P2P napojuje, tvari se jak kokosky, ze u nich dle serioveho č. vse ok. Jebat na ne, udelal sem si VPN na jinou pripojku s verejkou a nazdar bazar. Mam tam VPN / L2TP ale mrzne to co den dva... musim dis/ena klienta a pak to zas chvili jede...
0 x
Umřel sem, tak do mě nekopte a nechte mne spát... budoucnost bezdrátových sítí je jen mimo venek, kdo doteď nezačal s budováním optických sítí, půjde do 4 let pod drn...

hanzIT
Příspěvky: 43
Registrován: 2 years ago

Příspěvekod hanzIT » 4 months ago

Maverick_BK píše:Nevim co mas za system ale jsou vyrobci kde jde pristupovat pres jejich cloud (P2P).


No ale pres ten Cloud se nedstanes do weboveho rozhrani...je to myslim jen pro mobilni aplikace a programy pro primy pristup....

Jinak jedna se o kamery i NVR od Cantonku...je to docela SRA*CKA a nikomu radeji nedoporucuji cokoliv od teto firmy kupovat...
0 x

hanzIT
Příspěvky: 43
Registrován: 2 years ago

Příspěvekod hanzIT » 4 months ago

mpcz píše:Přijde mi to tak, že jsi to ještě ani nezkusil. Nebo je to připojeno za nestandardních podmínek.
Také není špatné popsat, co jsou na obou koncích za routery. Pokud něco jednoduchého, tak to pořeší pak asi dvě 5-ti portové RB750-ky (á 700,- + DPH). Pokud ti to bude pasovat finančně, určitě ti někdo tady poradí, jak to nastavit. mpcz, 29.7.2018


U klienta je staricky TP-LINK u me doma pak Mikrotik typ tedkom z hlavy nevim, ale provozuji na nem DUDE server...cenove kolem 1300Kc...
0 x

Uživatelský avatar
Myghael
Příspěvky: 1220
Registrován: 7 years ago

Příspěvekod Myghael » 4 months ago

pcwifi píše:me Dahua tak dojebali jeden NVR, ze to jejich P2P uz vubec nejede, kdyz jim pisu ze mi nejde zarizko pridat do toho jejich SW co se pres P2P napojuje, tvari se jak kokosky, ze u nich dle serioveho č. vse ok. Jebat na ne, udelal sem si VPN na jinou pripojku s verejkou a nazdar bazar. Mam tam VPN / L2TP ale mrzne to co den dva... musim dis/ena klienta a pak to zas chvili jede...


Přesně můj příběh, po podobných zkušenostech už na cloudy výrobců ze zásady seru a jedu VPN, i klienti jsou s tím v pořádku, ostatně připojit se na VPN domů je v posledních verzích Androidu a iOS opravdu jednoduché. Jen teda moje VPNky mají zpravidla uptime omezený jen posledním upgradem mého mikrotiku. :D

hanzIT píše:No ale pres ten Cloud se nedstanes do weboveho rozhrani...je to myslim jen pro mobilni aplikace a programy pro primy pristup....

Jinak jedna se o kamery i NVR od Cantonku...je to docela SRA*CKA a nikomu radeji nedoporucuji cokoliv od teto firmy kupovat...


Jinými slovy, nas*at a rozmazat.

hanzIT píše:U klienta je staricky TP-LINK u me doma pak Mikrotik typ tedkom z hlavy nevim, ale provozuji na nem DUDE server...cenove kolem 1300Kc...

Ať je to cokoliv, pokud na tom jede Dude server, pak to má výkonu dost. U klienta tedy TP-Link nahradit nějakou RB75x (RB750 nebo RB751, je-li potřeba Wi-Fi) popř. RB9x1 (RB931 / hAP mini, RB941 / hAP lite, 951... - o kousek výkonnější, wifi mají všechny) a máš to zároveň s upgradem. Některé novější TP-Linky už VPN umí taky, ale to by pak klient posílal přes tebe všechen traffic a to už by tak fajn nebylo. Takže mikrotika a je vystaráno, jediná konfigurace bude na tvém mikrotiku a na tomhle, tj. ta nejlepší, nejspolehlivější a zároveň nejsnadnější verze.
1 x
Si vis pacem, para bellum.

MikroTik, UBNT, Cisco, TP-Link... rozhoduje vhodnost toho či onoho pro konkrétní použití, ne jaké logo nalepili v Číně na krabici. Na tomto fóru vystupuji jen a pouze sám za sebe.

hanzIT
Příspěvky: 43
Registrován: 2 years ago

Příspěvekod hanzIT » 4 months ago

Dekuji prozatim Vsem za napady a rady. Zkusim mikrotika...snad se nejak pobiju s konfiguraci...snad neco bude na YouTube :-)

dik

HIT
0 x

hanzIT
Příspěvky: 43
Registrován: 2 years ago

Příspěvekod hanzIT » 1 month ago

Myghael píše:Něco podobného už jsem řešil, ve finále se na místo prostě umístil mikrotik (v mém případě prastarý RB133, který jsem měl zrovna po ruce), jehož jediným účelem je vytáčet VPN na server u mě doma (router mám mikrotik i tak, takže bez problému). Pokud můžeš na tom místě bez veřejné IP vyměnit router za mikrotika, je to prosté, při vytváření profilu pro připojení přidáš routu, která bude při aktivním spojení aktivní. Na straně klienta (u těch kamer) jen přidáš statickou routu do domovské sítě přes ten tunel a je vystaráno. Pokud nelze rovnou tím mikrotikem nahradit (V mém případě DOCSIS modem bez možnosti bridge módu), pak buď musíš na tom cílovém zařízení přidat statickou routu (do tvé sítě, jako bránu lokální adresu toho mikrotika), nebo si na tom mikrotiku udělat NAT.


Ahoj,

chtel bych te poprosit o radu, jak to nastavit. Stacilo by mi par screenu. Tj. klient, server a ta routa...s mikrotikem moc nemumim, ale ucim se...dekuji za pomoc i ochotu
0 x

Uživatelský avatar
Myghael
Příspěvky: 1220
Registrován: 7 years ago

Příspěvekod Myghael » 1 month ago

hanzIT píše:Ahoj, chtel bych te poprosit o radu, jak to nastavit. Stacilo by mi par screenu. Tj. klient, server a ta routa...s mikrotikem moc nemumim, ale ucim se...dekuji za pomoc i ochotu

Je to prosté, předpokládejme nyní, že v tvé síti (kde ti jede ten mikrotik s DUDE serverem) používáš rozsah 192.168.10.0/24, vzdálená síť s tím kamerovým systémem bude používat třeba 192.168.11.0/24. Tento příklad používá jako VPN protokol PPTP, který již není považován za bezpečný. Funguje dobře a kdejaký jouda ti to nenabourá, ale do budoucna pozkoumej jinou VPNku, třeba L2TP/IPsec.

Nejprve si nakonfiguruješ ten mikrotik u sebe - vytvoříš si uživatelský účet (PPP->secrets), v něm kromě jména/hesla a podobně přidáš také routu pro síť 192.168.11.0/24 - tato tedy bude u tebe doma aktivní jen v případě, že je klient připojen - jako bránu pro tuto routu použij tutéž adresu, kterou bude v tunelu mít klientský mikrotik, tedy totéž, cos zadal do políčka Remote IP. Ta jednička na konci je distance, to nech stejné. No a samozřejmě zapneš příslušný server a ve firewallu povolíš připojení k němu.

Kód: Vybrat vše

/interface pptp-server
add comment="Kamerovy_system" name=pptp-in1 user=TvujLogin
/interface pptp-server server
set enabled=yes
/ppp secret
add comment=kamery local-address=192.168.253.1 name=TvujLogin password=DobreHeslo profile=default-encryption remote-address=192.168.253.2 routes="192.168.11.0/24 192.168.253.2 1"


V druhé fázi si nastavíš toho klientského mikrotika. Nejprve ten základ jako LAN IP, DHCP, WAN... Osobně používám na konfiguraci všeho DHCP (pak snadno vidím, že zařízení si po restartu ani nelízlo IP, navíc je to pak podobnější s nastavením pro IPv6 a také můžu snadno všem zařízením najednou posílat vždy aktuální adresy DNS/NTP a další parametry), takže případně statický příděl pro DVR a jednotlivé kamery (jsou-li IP a připojeny do stejné sítě). Až budeš mít vše rozchozeno jako dosud, tak vytvoříš VPN klienta, se kterým se připojíš na ten svůj VPN server, dále pak v IP->Routes přidáš statickou routu do sítě 192.168.0.0/24, jako bránu to co má protilehlý mikrotik.

Kód: Vybrat vše

/interface pptp-client
add comment="Management VPN" connect-to=verejnaIPtvehoMikrotika disabled=no name=pptp-out1 password=DobreHeslo user=TvujLogin
/ip route
add distance=1 dst-address=192.168.10.0/24 gateway=192.168.253.1


To vše je samozřejmě zapotřebí doplnit pravidly do firewallu, kterými si povolíš provoz mezi sítěmi. Přidám pravidla na povolení přístupu k PPTP VPN na tvojí straně, zbytek ti ponechám jako cvičení, případně pomůžu i s tím.

Kód: Vybrat vše

/ip firewall filter
add action=accept chain=input comment="Allow connection to PPTP VPN (tunnel maintenance)" dst-port=1723 in-interface=ether6 protocol=tcp
add action=accept chain=input comment="Allow connection to PPTP VPN (tunneled data)" in-interface=ether6 protocol=gre


V případě použití dnes více doporučeného protokolu L2TP a IPsec namísto zde použitého staršího PPTP je vše podobné, princip se nijak nemění.
0 x
Si vis pacem, para bellum.

MikroTik, UBNT, Cisco, TP-Link... rozhoduje vhodnost toho či onoho pro konkrétní použití, ne jaké logo nalepili v Číně na krabici. Na tomto fóru vystupuji jen a pouze sám za sebe.

hanzIT
Příspěvky: 43
Registrován: 2 years ago

Příspěvekod hanzIT » 1 month ago

Dekuji za nakopnuti spravnym smerem. Az ted jsem si poridil druhy MT a laboruji s tim. Omlouvam se za blby dotaz, ale co jsou to ty adresy 192.168.253.2 a 192.168.253.1 ...fakt s tim zacinam... kde jsi je vzal?

O nebezpecnosti PPTP vim. Jen to zkousim a urcite prejdu na lepsi zabezpeceni. Zatim se to snazim nejak pochopit.

Jinak ten vypis kodu od tebe...to se da takto vlozit primo neco jako ctrl+c ctrl+v?

dekuji

H.
0 x

Daxxim
Příspěvky: 346
Registrován: 6 years ago
Kontaktovat uživatele:

Příspěvekod Daxxim » 1 month ago

hanzIT píše:Dekuji za nakopnuti spravnym smerem. Az ted jsem si poridil druhy MT a laboruji s tim. Omlouvam se za blby dotaz, ale co jsou to ty adresy 192.168.253.2 a 192.168.253.1 ...fakt s tim zacinam... kde jsi je vzal?

O nebezpecnosti PPTP vim. Jen to zkousim a urcite prejdu na lepsi zabezpeceni. Zatim se to snazim nejak pochopit.

Jinak ten vypis kodu od tebe...to se da takto vlozit primo neco jako ctrl+c ctrl+v?

dekuji

H.


To jsou spojovací ip adresy na obou koncích tunelu. Doporučuju pročíst https://wiki.mikrotik.com/wiki/Manual:Interface/PPTP

edit: ten kod se dá vložit například do teminálu a provede se
0 x


Zpět na „Začátečnické témata“

Kdo je online

Uživatelé prohlížející si toto fórum: mlickocz a 4 hosti