Nastavení VLAN CSS/CRS 326-24G-2S+

Návody a problémy s konfigurací.
puchnar
Příspěvky: 192
Registrován: 3 years ago

Nastavení VLAN CSS/CRS 326-24G-2S+

Příspěvekod puchnar » 6 days ago

Zdravím, omlouvám se za poněkud amatérský dotaz ale už si nevím rady, nejspíš se ale bude jednat o začátečnickou chybu :)
1. Topologie CCR (sfp1+)--> (p28) TPLINK T1700G-28TQ (p26) --> (sfp+2)CRS 326
Na CCR mám vytvořené vlany 801,802,325 a 201-224, ty 2XX jsou přiděleny jednotlivým portů toho TPLINKU to funguje
Na portu 26 toho TP-Linku mám nastaveno 325,801,802 tagged a 1 untagged
2. Nejsem schopný na tom CRS ku rozchodit ty VLANY, chci aby na p1-8 byla untagged 1, p9-16 untagged 801, p17-24 untagged 802, sfp+1 untagged 325
Nastavení jsem zkoušel mnoho, ale nejdál jsem se dostal s konfigurací níže. V tomto stavu na všech portech dostanu IP Adresu ze správné VLANy, ale žádný provoz nechodí, dokonce se nedostanu na to CCR ani přes MAC, zajímavé je, že i když ten switch restnu do defaultu, tak ani ten netagovaný 1 provoz ten switch neswitchuje, dostanu IP ale provoz nechodí (začne chodit v momentě kdy přepnu sfp2+ do VLAN Mode enabled a do tabulky dám 1 VLAN pro všechny porty, jakmile ale přidám do tabulky další VLAN, provoz se okamžitě zastaví. Před tím tam bylo místo CRS CISCO které tak bylo nastaveno a vše fungovalo, ale to je mrtvé a zákazník tam jiný switch nechce. RSTP vypnuté. Určitě je to jen nějaká blbost z mé strany :) Díky moc za jakékoliv nakopnutí ať už ku pomoci nebo někam jinam :)

3. Prošel jsem návody od mikrotiku určené pro CSS 326 a mají to tam nastavené takto, tak nevím....,prošel jsem i velkou část příspěvku ohledně VLAN zde na foru ale nenašel jsem nic co by mi pomohlo s řešením.

EDIT1: v té VLAN Tabulce ten port10 u 801 není zatržený schválně mám tam testovací PC, ale jinak samozřejmě zatrhnout patří
vlan 2.png
vlan 2.png (10.78 KiB) Zobrazeno 802 x

vlan 2.png
vlan 2.png (10.78 KiB) Zobrazeno 802 x
Přílohy
vlan 1.png
vlan 1.png (45.17 KiB) Zobrazeno 802 x
0 x

TheITman
Příspěvky: 149
Registrován: 3 years ago

Příspěvekod TheITman » 6 days ago

Tohle by mě zajímalo taky, na pár místech mám CSS 326 a netuším jak jsem to tenkrát dal dohromady, taky jsem nad tím strávil několik desítek hodin a bojím se na to sáhnout.
0 x

puchnar
Příspěvky: 192
Registrován: 3 years ago

Příspěvekod puchnar » 5 days ago

Případně někdo kdo to za nějakou úplatu dá dohromady?
0 x

dagus
Příspěvky: 1452
Registrován: 9 years ago

Příspěvekod dagus » 5 days ago

Úplata je jasná, kup hpe a máš to. Pokud potřebuješ 24V tak ubnt. Mikrotik a vlan jsem vzdal a jediné vlany používám na x86 trunk.
1 x

S_a_M
Příspěvky: 703
Registrován: 4 years ago
Bydliště: Protektorat Böhmen und Mähren

Příspěvekod S_a_M » 5 days ago

Zkus the.max ten si s tim rozumi za men TPLink, HPE, Cisco, Huawei cokoliv co funguje rozumnym zpusobem Mikrotik je takovej zajimavej :D ale the.maxovi to chodi co vim.
Edit:
Eeee sorry jsem si nevsim ze ti to bezi ve SwitchOS jako bych nic nerek....
Naposledy upravil(a) S_a_M dne 12 Feb 2020 23:14, celkem upraveno 1 x.
0 x
Placam si jatra, tak mne neberte vazne :)
Ceragona uz mi tak nevadi. Vadi mi ovsem ze kuci v CEZu nedelaj svoji praci tak jak maj !!!

ludvik
Příspěvky: 4487
Registrován: 8 years ago

Příspěvekod ludvik » 5 days ago

Nějak se mi nezdá prohlášení, že dostaneš správnou IP (předpokládám DHCP), ale provoz nechodí. I to DHCP je přeci provoz oběma směry ...

Možná bych se zaměřil na to port isolation. Používáš-li VLANy, tak nechápu jeho potřebu a vliv na ty VLANy.
0 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.

puchnar
Příspěvky: 192
Registrován: 3 years ago

Příspěvekod puchnar » 4 days ago

Ano opravdu dostanu ip od správného DHCP Serveru, stejně tak vidím v leases to zařízení. Když si nechám přidělit ip ze stejného rozsahu jako je switch a router 172.16.1.241-router 242-tplink 244-CSSswitch a 243 pc ze kterého to nastavuju tak na 244 si pingnu a dostanu se na něj ale na 241, 242 už ne.

To port isolation také moc nechápu ale i když to vyhodím tak to nefunguje.
0 x

iTomB
Příspěvky: 953
Registrován: 13 years ago

Příspěvekod iTomB » 4 days ago

No jeste bych prosel to, jak ti to chodi z TPlinku, aby se to nehadalo, kdyz to dorazi na mikrotika. Duvod proc chces nektere porty untag 1? Doporucil bych to dat taky do nejake VLANy a vse strikne VLANovat. Misto enabled, jsem se naucil pouzivat strict a funguje. Bezne takhle pouzivam RB260GS ci CRS106. Obcas jsem zazil, ze PC i kdyz byl blbe nastaven vystup ze switche sel, ale dalsi veci ne. Jako by si PC odvodil VLANu a nejak si ji pak pridaval sam, neco jako ze data prijdou tagovana a to co poslu zpet je netagovane a switch je taguje. Mozna si tam zkus dat RBcko s ROS, kde das porty do bridge a tam si dat torch.
0 x

puchnar
Příspěvky: 192
Registrován: 3 years ago

Příspěvekod puchnar » 3 days ago

Ten TP-Link je klikacka tam je si u té vlany jen kliknu jestli ji chci tag nebo untag. Ok zkusím vše na vstupu tagovat a untag 1 se zbavit měl jsem ji tam hlavně kvůli tomu když třeba místo switche tam pichnu PC abych tam měl nějakou untag síť :) zatím Díky :)
0 x

coolerman1
Příspěvky: 412
Registrován: 12 years ago

Příspěvekod coolerman1 » 3 days ago

mne ked kolega vysvetloval Vlany ,tak jedine Cisco😬,mame vecsinu siete na L2 a Vlany
0 x

miso7711
Příspěvky: 75
Registrován: 1 year ago

Příspěvekod miso7711 » 3 days ago

nakresli topologiu a posli ID teamu...
0 x

puchnar
Příspěvky: 192
Registrován: 3 years ago

Příspěvekod puchnar » 3 days ago

Takže nakonec díky iTomB, který mě nasměroval vyřešeno. V této konfiguraci byly dva problémy, jednak untag vlan 1 kde po jejím odstranění se provoz na 2 vlanách rozběhnul a na 2 ne, což bylo způsobenou tím, že pokud mám dvě VLANY na dvou portech toho switche a dám je na routeru do Bridge tak se staně přesně to, že dostanu správnou IP ale provoz nechodí. Dokázal by někdo vysvětlit proč? Každopádně po odbridgování těch dvou VLAN všechny VLANY na tom switchi fungují tak jak mají, takže vyřešeno a všem tímto moc děkuji.
0 x

ludvik
Příspěvky: 4487
Registrován: 8 years ago

Příspěvekod ludvik » 3 days ago

Ty jsi měl dvě různé VLANy, které jsi následně spojil do bridge? To je opravdu nezvyklá a dost zbytečná konfigurace.
0 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.

puchnar
Příspěvky: 192
Registrován: 3 years ago

Příspěvekod puchnar » 3 days ago

to bylo při konfiguraci abych na jedné vlan (kterou jsem ještě neměl k čemu přiřadit) mohl otestovat funkčnost :)
0 x

ludvik
Příspěvky: 4487
Registrován: 8 years ago

Příspěvekod ludvik » 3 days ago

V každém případě se ukazuje, že pokud nedáš dostatek informací, tak se vaří z vody a hádá z křišťálové koule. Neměl jsi problém tam, co jsi popisoval.

Ono šaškovat s takovým nastavením je prostě duchařina. Leccos funguje, někdy ovšem ne. Někdy ti do toho zasáhne stp na bridgi, někdy na switchi. Pakety si běhají tam, kde nemají a tam kde mají neběhají.
Příště dej prostě víc informací. Třeba bychom problém hledali tam, kde je (na routeru) a ne tam, kde nejspíš není (na switchi).
Teoreticky: https://wiki.mikrotik.com/wiki/Manual:L ... idged_VLAN
0 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 4 hosti