Mikrotik + VDSL modem s PPPOe jako bridge?

Návody a problémy s konfigurací.
Rytir
Příspěvky: 5
Registrován: 8 months ago

Mikrotik + VDSL modem s PPPOe jako bridge?

Příspěvekod Rytir » 8 months ago

Mám 1GB ethernet Mikrotik a připojení na internet přes VDSL modem Huawey HG622u a rád bych měl onu veřejnou IP na jednom z interface mikrotiku, pořekněmě eth1.
Jak na to?
Má představa
Od providera dostnu veřejnou IP pomocí PPPOe protokolu nastvim na modemu, pak přepnu modem do bridge , vypnu NAT, DHCP Server, WIFI a nechám IP 10.0.0.138.
Pak na Mikrotiku pro eth 1 zapnu DHCP Clienta a veřejná IP by měla byt na eth1 nebo se pletu?
Na mikortiku je i možnost zapnou něco jako PPPOe Clienta, k čemu to je dobré?
Co gateway, je nějaký rozdíl mezi tim, pokud nastvím přidělenou veřejnou IP nebo nastvím rovnou rozhraní eth1?
Proč jsme nehcal 10.0.0.38, on je modem vlastně pro moji vnitřní sít již za WAN a tak předpokjládám, že mikrotik v siti 192.168.0.0/24 předá požadavem na WAN a tam skončíé v modemu enbo také ne?
0 x

sutrus
Příspěvky: 81
Registrován: 1 year ago

Příspěvekod sutrus » 8 months ago

Modem HG622u překonfigurovat do mode Bridge a v mikrotiku nastavit korektně PPPoE.
Popřípadě v modemu nastavit DMZ.
0 x

Rytir
Příspěvky: 5
Registrován: 8 months ago

Příspěvekod Rytir » 8 months ago

Už to vidím, nemam tu modem, tak koukam jen do manualu k modemu https://www.o2.cz/_pub/6b/94/dd/241521_524990_Manual_CZ_v1._11.pdf
jakmile je na WAN modmeu zvolen bridging tak se PPPOe nenastvuje na modemu,ale prolézá to dál a logicky se musí nastvit na interface mikrotiku.
Předpokládám, že na mikrotiku stačí na eth1 v PPPOe nastavit max MTU, max MRU na 1480 , uživatelské jméno a heslo plus zaškrtnout Use Peer DNS pro převzetí DNS od providera.

To je myslim jasné, co ale nechápu je stále přístup na modem z LAN, zafunguje to tak jak jsem napsal v prvním příspěvku? Tedy modem ma dfefaultní 10.0.0.138 a přístup na Ip,. které neneí z LAN tak jako tak směruje na WAN a tam na ni odpovi modem?
0 x

_piggy_
Příspěvky: 140
Registrován: 1 year ago
Bydliště: Znojmo

Příspěvekod _piggy_ » 8 months ago

VDSl modem přepnout do bridge, odstranit jak je psáno nat,dhcp atd..
V mikrotiku pak vytvořit PPPOe client a zadat user a password - sám to takto mám.
Přílohy
xxxx.png
xxxx.png (163.07 KiB) Zobrazeno 2605 x
0 x

Rytir
Příspěvky: 5
Registrován: 8 months ago

Příspěvekod Rytir » 8 months ago

PPPOe Client zafungoval perfektně , v podstatě to co jsem přednastavil zafungovalo. Nicmnéně vyskytl se jiny "problém", Nastavil jsem statické DNS něco jako

Kód: Vybrat vše

/ip dns static
​add address=192.168.0.10 name=NAS

předpokládal jsem, že když následně zadám ping NAS , přeloží se mi to na ping 192.168.0.10, ale nějak mi to nefunguje, nemuže to souviset s "​Use Peer DNS" v PPPOe? Případně kde hledat problém? DNS jako takové fuguje, ale to co mám v Static jako by neexitovalo i kdy mam jako DNS nastaveno 192,168,0,1 tedy ten Mikrotik
Děkuji
0 x

sutrus
Příspěvky: 81
Registrován: 1 year ago

Příspěvekod sutrus » 8 months ago

Je potřeba povolit v DNS mikrotiku "allow remote request".
Pak je potřeba ve firewallu zakázat dns požadavky z wan.
0 x

Rytir
Příspěvky: 5
Registrován: 8 months ago

Příspěvekod Rytir » 8 months ago

"allow remote request" povoleno nám, požadavky na 53 z WAN zakázané nemám, ale to by snad nemělo mit vliv na funkci.

V každém případě to nefungujem respektive jak jsem ted zjisitl funguje to tak nějak jinak než jsem si myslel, že to fungovat ma.
Domnival jsem se, že DNS prostě nahradí daný ASCI žetězec k řetězci přiřazenou IP.
Pokud ale v static DNS nám

Kód: Vybrat vše

add address=192.168.0.3 name=wifi
add address=192.168.0.4 name=wifi.lan

bude fungovat jen ping wifi.lan a ping wifi se nepodaří najít hostitele

Jak to?
Naposledy upravil(a) Rytir dne 11 Nov 2018 23:36, celkem upraveno 1 x.
0 x

Uživatelský avatar
goblajz
Příspěvky: 824
Registrován: 11 years ago
antispam: Ano

Příspěvekod goblajz » 8 months ago

Maškarádu tam máš?

/ip firewall nat add action=masquerade chain=srcnat out-interface=PPPoE_interface
0 x

Rytir
Příspěvky: 5
Registrován: 8 months ago

Příspěvekod Rytir » 8 months ago

Ani mámm jinak vše funguje včetmě port forwarding a dalších věci.
Ted jsme zeditoval sůj příspěvek výše, ono vlastně chodí i to statické DNS, ale jen pro nazvy ve formýtu xxxx.yyy a xxx nefunguje viz výše
0 x

sutrus
Příspěvky: 81
Registrován: 1 year ago

Příspěvekod sutrus » 8 months ago

Rytir píše:"allow remote request" povoleno nám, požadavky na 53 z WAN zakázané nemám, ale to by snad nemělo mit vliv na funkci.

Na funkci to vliv určitě nemá. Musíš si uvědomit, že máš veřejnou IP adresu a mikrotik odpovídá na i na požadavky DNS z internetu.
Je jen otázka času než DNS server mikrotiku někdo zneužije k útoku.
0 x

Radek.Kovacik
Příspěvky: 112
Registrován: 6 years ago

Příspěvekod Radek.Kovacik » 5 months ago

Když mám MT s PPPoE klientem a modem v bridge, je nutné na Mikrotiku zapnout DHCP klienta nebo ne? Nebo na tom nezáleží? Provider mi poskytuje veřejnou IP dynamicky (i když v praxi se v podstatě nemění a mám pořád stejnou adresu) a aktuálně to mám bez DHCP klienta a funguje to. Pouze jsem musel přidat statickou routu.
0 x

ssnakess
Příspěvky: 141
Registrován: 7 years ago

Příspěvekod ssnakess » 4 months ago

Dobrý den,

nechci zakládat nové vlákno. Nevíte co je za problém, že v logu se mi stále objevuje, že se odpojuje a připojuje? Jednou je to za 10m a jednou za 30m.
Je to RB2011 v6.43.8 a VDSL O2. Včera jsem to celý překopal a nepomohlo to.
Přílohy
VDSL.png
VDSL.png (57.1 KiB) Zobrazeno 1303 x
0 x

Rosak
Příspěvky: 190
Registrován: 6 years ago

Příspěvekod Rosak » 4 months ago

Takhle se mi to začalo chovat na lince od Vodafone před pár měsíci. Do té doby jsem měl přes rok pořád stejnou IP adresu (dynamickou) a žádné výpadky. Pak se doba přidělení stejné IP adresy začala zkracovat až na v řádu pár dnů a najednou šup a měl jsem neveřejnou. Když jsem se po dlouhých peripetiích na jejich hotlajně dostal až k člověku, který znal rozdíl statická/dynamická řekl mi, že Vodafone přechází na nový "model", protože lidé "moc využívali veřejnou adresu" :-D Takže od teď už budou mít všichni pouze neveřejnou a veřejnou si mohou doplatit za měsíční poplatek.
0 x

ssnakess
Příspěvky: 141
Registrován: 7 years ago

Příspěvekod ssnakess » 4 months ago

No je tam dynamická veřejná IP, neplacená. Stále mi volají z O2, zda nechci navýšit rychlost na 50Mbit za příplatek 50kč/měs.. Je mi jasný, že když řeknu ano, tak o tu veřejku přijdu jako mnohokrát jinde u známých.
A jak jste to nakonec vyřešil nebo nevyřešil? Nebo je to v pořádku, že se stále připojuje a odpojuje?

Rosak píše:Takhle se mi to začalo chovat na lince od Vodafone před pár měsíci. Do té doby jsem měl přes rok pořád stejnou IP adresu (dynamickou) a žádné výpadky. Pak se doba přidělení stejné IP adresy začala zkracovat až na v řádu pár dnů a najednou šup a měl jsem neveřejnou. Když jsem se po dlouhých peripetiích na jejich hotlajně dostal až k člověku, který znal rozdíl statická/dynamická řekl mi, že Vodafone přechází na nový "model", protože lidé "moc využívali veřejnou adresu" :-D Takže od teď už budou mít všichni pouze neveřejnou a veřejnou si mohou doplatit za měsíční poplatek.
0 x

zip
Příspěvky: 71
Registrován: 8 years ago

Příspěvekod zip » 4 months ago

Moje konfigurace pro O2 modem ..

/interface pppoe-client
add add-default-route=yes dial-on-demand=yes disabled=no interface=ether01 keepalive-timeout=60 max-mru=1480 max-mtu=1480 name=o2 password=O2 service-name=br_8_48 use-peer-dns=yes user=O2
1 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 2 hosti