OVPN routing

Návody a problémy s konfigurací.
atomic1977
Příspěvky: 115
Registrován: 12 years ago

OVPN routing

Příspěvekod atomic1977 » 4 days ago

Mám rozběhlý ovpn server na MK routeru ip 172.16.0.1 Local IP tunelu 10.50.10.1 Remote 10.50.10.10 přes IP 10.50.10.1 se na router připojím ,ale né na klienty v síti toho routeru 172.16.0.0/24 a jiné jako např 10.1.10.0/24 atd. Jak mám nastavít routování abych se byl schopný připojit na všechny sítě nahozené na tom routeru ? Připojuji se většinou přes mobilní připojení.
0 x

mirek.k
Příspěvky: 608
Registrován: 10 years ago

Příspěvekod mirek.k » 4 days ago

Čím se připojujete?
0 x

atomic1977
Příspěvky: 115
Registrován: 12 years ago

Příspěvekod atomic1977 » 4 days ago

Jsem psal ,že většinou přes mobilní připojení buď T-mobile nebo Vodafone.
0 x

mirek.k
Příspěvky: 608
Registrován: 10 years ago

Příspěvekod mirek.k » 4 days ago

Jakým zařízením?
0 x

K3NY
Příspěvky: 214
Registrován: 2 years ago

Příspěvekod K3NY » 4 days ago

mas mode IP? Ja bych teda rekl ze tam musis mit maskaradu aby ti to behalo.
0 x

fujara
Příspěvky: 85
Registrován: 12 years ago

Příspěvekod fujara » 4 days ago

atomic1977 píše:Mám rozběhlý ovpn server na MK routeru ip 172.16.0.1 Local IP tunelu 10.50.10.1 Remote 10.50.10.10 přes IP 10.50.10.1 se na router připojím ,ale né na klienty v síti toho routeru 172.16.0.0/24 a jiné jako např 10.1.10.0/24 atd. Jak mám nastavít routování abych se byl schopný připojit na všechny sítě nahozené na tom routeru ? Připojuji se většinou přes mobilní připojení.


/ip route
add distance=1 dst-address=172.16.0.0/24 gateway=ovpn-out1
add distance=1 dst-address=10.1.10.0/24 gateway=ovpn-out1
0 x

atomic1977
Příspěvky: 115
Registrován: 12 years ago

Příspěvekod atomic1977 » 3 days ago

mirek.k píše:Jakým zařízením?


Připojuji se windows klientem
0 x

mirek.k
Příspěvky: 608
Registrován: 10 years ago

Příspěvekod mirek.k » 3 days ago

atomic1977 píše:
mirek.k píše:Jakým zařízením?


Připojuji se windows klientem

Pak je potřeba ve Windows přidat routy pro vzdálené sítě s bránou IP tunelu OpenVPN.
Je to v CMD příkaz route.
0 x

atomic1977
Příspěvky: 115
Registrován: 12 years ago

Příspěvekod atomic1977 » 3 days ago

fujara píše:
atomic1977 píše:Mám rozběhlý ovpn server na MK routeru ip 172.16.0.1 Local IP tunelu 10.50.10.1 Remote 10.50.10.10 přes IP 10.50.10.1 se na router připojím ,ale né na klienty v síti toho routeru 172.16.0.0/24 a jiné jako např 10.1.10.0/24 atd. Jak mám nastavít routování abych se byl schopný připojit na všechny sítě nahozené na tom routeru ? Připojuji se většinou přes mobilní připojení.


/ip route
add distance=1 dst-address=172.16.0.0/24 gateway=ovpn-out1
add distance=1 dst-address=10.1.10.0/24 gateway=ovpn-out1


Tohle nefunguje tuto routu si nahodí mk sám.
0 x

mirek.k
Příspěvky: 608
Registrován: 10 years ago

Příspěvekod mirek.k » 3 days ago

To musíš řešit na straně klienta, ne na straně serveru.
Pokud máš jako klienta Windows, tak v nich.
Předchozí ukázka předpokládala, že klient je také mikrotik.
0 x

atomic1977
Příspěvky: 115
Registrován: 12 years ago

Příspěvekod atomic1977 » 3 days ago

mirek.k píše:To musíš řešit na straně klienta, ne na straně serveru.
Pokud máš jako klienta Windows, tak v nich.
Předchozí ukázka předpokládala, že klient je také mikrotik.


Už to jede díky za nakopnutí.
0 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 17 hostů