L2TP/IPSEC

Návody a problémy s konfigurací.
Uživatelský avatar
mac0112
Příspěvky: 355
Registrován: 9 years ago
antispam: Ano
Bydliště: Klecany
Kontaktovat uživatele:

Re: L2TP/IPSEC

Příspěvekod mac0112 » 2 years ago

maartinek píše:Tak, zde je moje konfigurace. Připojuji se z platforem Mikrotik, Windows 7/10, Android a Windows Phone. Prosím, pokud tam někdo najde něco, co vylepšit, budu jen rád, protože vždy je co vylepšit.... Snad jsem na nic nezapomněl.

IP adresy 192.168.xx.xx si samozřejmě nahraďte svýma platnýma IP.

Kód: Vybrat vše

/interface l2tp-server server
set authentication=mschap2 default-profile=l2tp/ipsec enabled=yes max-mru=1460 max-mtu=1460

/ppp profile
add address-list=VPN change-tcp-mss=yes incoming-filter=rw-in local-address=192.168.xx.xx name=l2tp/ipsec remote-address=pool-vpn use-encryption=required use-upnp=no

/ppp secret
add name=JmenoUzivatele password="TajneHeslo123" profile=l2tp/ipsec service=l2tp

/ip pool
add name=pool-vpn ranges=192.168.xx.xx-192.168.xx.xx

/ip dhcp-server network
add address=192.168.xx.xx/24 comment=VPN gateway=192.168.xx.xx netmask=24

/ip ipsec peer
add address=0.0.0.0/0 enc-algorithm=aes-256,3des exchange-mode=main-l2tp generate-policy=port-override local-address=0.0.0.0 passive=yes policy-template-group=gr-l2tp/ipsec secret=PreSharedKeyPWD send-initial-contact=no

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-192-cbc,aes-128-cbc,3des pfs-group=modp4096
add enc-algorithms=aes-256-cbc name=prop-l2tp/ipsec pfs-group=modp4096

/ip firewall filter
add action=accept chain=input comment="Nepust dovnitr L2TP  bez IPsec obalky" dst-port=1701 ipsec-policy=in,ipsec log-prefix="" protocol=udp
add action=drop chain=input dst-port=1701 log-prefix="" protocol=udp
add action=accept chain=output comment="Nepust ven L2TP odpoved serveru bez IPsec obalky" ipsec-policy=out,ipsec log-prefix="" protocol=udp src-port=1701
add action=reject chain=output log-prefix="" protocol=udp reject-with=icmp-network-unreachable src-port=1701
add action=accept chain=input comment="wan-in: IPsec, IKEv1, IPsec over UDP" connection-state=new log-prefix="" protocol=ipsec-esp
add action=accept chain=input connection-state=new dst-port=500,4500 log-prefix="" protocol=udp
add action=jump chain=input comment="filtr na data od road-warriors" jump-target=ppp log-prefix=""
add action=jump chain=forward jump-target=ppp log-prefix=""
add action=accept chain=rw-in comment="=== rw-in: co jde od road-warriors pres VPN povolit" connection-state=new log-prefix=""


Tato konfigurace funguje skvěle. Do podnikové sítě VPNkem L2tp se přihlásím i do každého počítače ale sdílené disky Win serveru v práci si nemohu doma na svém notebooku s Win namapovat. Přitom PPTP spojení na mém notebooku namapování funguje.
Můžete mi poradit v čem je problém ?
Verze 6.34.2
0 x

joker
Příspěvky: 434
Registrován: 9 years ago
antispam: Ano

Příspěvekod joker » 9 months ago

Mám mikrotik a do neho se prihlasim pres VPN L2TP (ne ipsec) z iOS (iphone/ipad) ... OK

Mam windows7 a zde nevim, jak mam pripojeni nakonfigurovat, abych se pripojil podobne jako tim iOS klientem

Ze stejne site...

Prosim o nakopnuti, kde se to v tom Windoze nastavuje, diky,
0 x

pavelsiman
Příspěvky: 280
Registrován: 2 years ago

Příspěvekod pavelsiman » 9 months ago

Riešim rovnaký problém. Všetko funguje. Nastavím aj android aj mac ale Windows ani tuk. Komplet nastavene aj predzdielany kľúč aj všetko. A nic
0 x

joker
Příspěvky: 434
Registrován: 9 years ago
antispam: Ano

Příspěvekod joker » 9 months ago

Nikdo nevi? Nepouzivate win7?
0 x

keksik
Příspěvky: 646
Registrován: 13 years ago

Příspěvekod keksik » 7 months ago

joker píše:Nikdo nevi? Nepouzivate win7?

Na mikrotiku na LAN skus zvolit proxy-arp.
0 x

joker
Příspěvky: 434
Registrován: 9 years ago
antispam: Ano

Příspěvekod joker » 7 months ago

No v mem pripade jsem asi ani nepochopil na strane Win7, kde se to L2TP nebo IPSEC konfiguruje, prosim o nakopnuti, diky
0 x

fujara
Příspěvky: 118
Registrován: 13 years ago

Příspěvekod fujara » 7 months ago

joker píše:No v mem pripade jsem asi ani nepochopil na strane Win7, kde se to L2TP nebo IPSEC konfiguruje, prosim o nakopnuti, diky

https://www.cactusvpn.com/tutorials/how ... windows-7/
Pravdepodobne nemas bod 9,10,11 (properties)...
0 x

basty
Příspěvky: 2125
Registrován: 13 years ago
Kontaktovat uživatele:

Příspěvekod basty » 5 months ago

Čau máte nějaký funkční návod na L2TP vpnku s ipsecem na mk pro win a android pro nový verze mk? Zkoušíme to nastavit ale nedaří se to rozbehat. Diky
0 x

hocimin1
Příspěvky: 1171
Registrován: 12 years ago
Bydliště: Náchod

Příspěvekod hocimin1 » 5 months ago

basty píše:Čau máte nějaký funkční návod na L2TP vpnku s ipsecem na mk pro win a android pro nový verze mk? Zkoušíme to nastavit ale nedaří se to rozbehat. Diky


V prvni rade je potreba nemit NATovanou verejku. To más splněno.
0 x

basty
Příspěvky: 2125
Registrován: 13 years ago
Kontaktovat uživatele:

Příspěvekod basty » 5 months ago

Ano.
0 x

hocimin1
Příspěvky: 1171
Registrován: 12 years ago
Bydliště: Náchod

Příspěvekod hocimin1 » 5 months ago

tak ja to mam takhle, se sdileným heslem, ktere je heslo

jo a myslim ze od nejake verze 6.36 doslo ke zmene, takze bylo potreba udelat upgrade na vyzsi verze nez 6.36 nebo 6.38 ted presne netusim

Kód: Vybrat vše

/ip pool
add name=VPN_POOL ranges=172.30.255.100-172.30.255.200

/ip ipsec policy group
set [ find default=yes ] name=group1
/ip ipsec proposal
set [ find default=yes ] disabled=yes enc-algorithms=des
add enc-algorithms=aes-256-cbc,3des name=L2TP-proposal pfs-group=none
/ip ipsec peer
add address=0.0.0.0/0 dh-group=modp1024 enc-algorithm=aes-256,aes-128,3des exchange-mode=main-l2tp generate-policy=port-override secret=heslo
/ip ipsec policy
add dst-address=0.0.0.0/0 proposal=L2TP-proposal src-address=0.0.0.0/0 template=yes

/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8 local-address=172.30.255.1 name=L2TP remote-address=VPN_POOL use-encryption=required

/ppp secret
add name=user2 password=L2tpheslo profile=L2TP remote-address=172.30.255.98 service=l2tp
add name=user1 password=L2tpheslo profile=L2TP service=l2tp

/interface l2tp-server server
set authentication=mschap2 enabled=yes ipsec-secret=heslo max-mru=1460 max-mtu=1460 use-ipsec=yes
0 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 12 hostů