Přístup na veřejnou IP z lokálního rozsahu

Návody a problémy s konfigurací.
Uživatelský avatar
okoun
Příspěvky: 6389
Registrován: 10 years ago
antispam: Ano
Bydliště: Mordor

Re: Přístup na veřejnou IP z lokálního rozsahu

Příspěvekod okoun » 1 year ago

hmm jinak jsem ještě zjistil že se to chová prapodivně a to že když server restartuji tak to chvilku chodí, pár hodin a potom zase ne což je divné...
0 x
Povoláním ISP není jen připojovat lidi k internetu, ale také jim dokázat vysvětlit, že bez pořádné investice do HW nelze udělat kvalitní přípojku a domácí síť...

Beny44
Příspěvky: 54
Registrován: 3 years ago

Příspěvekod Beny44 » 8 months ago

Mám obdobný problém

Provozuji dva webservery na jedné veřejné IP přes Web proxy a Static DNS v Microtiku. Z internetu vše OK, ale z vnitřní sítě se na weby dostanu jen s lokální adresou. Potřebuji ale, abych s vntřního rozsahu dostal ven a pak zpět. Je to nějak možné?
Mám apku k rosničce a stahuji k ní data odkazem http://www.neco.cz/data/... a nehci si odkaz pořád v apce měnit za lokální IP.
Harapin jsem testoval a asi vše nastavení co jsme na netu našel, ale nejde ani jedno.
Jen mě zaráží jedna věc, na začátku se zde mluví o tom, že NAT je třeba míti v IP adresách a ne v interface, což tedy už u maškarády mám jinak ..

/ip firewall nat
add action=masquerade chain=srcnat comment="hairpin nat" dst-address=10.0.0.0/24 src-address=10.0.0.0/24 src-address-type=local
add action=masquerade chain=srcnat out-interface=ether1
add action=dst-nat chain=dstnat comment=webka in-interface=ether1 port=9000 protocol=tcp to-addresses=10.0.0.201


Add: ještě jsem provedl změnu, ale stejný výsledek
0 chain=srcnat action=src-nat to-addresses=10.0.0.136 src-address=10.0.0.0/24 dst-address=10.0.0.0/24 log=no log-prefix=""

1 chain=srcnat action=masquerade src-address=10.0.0.0/24 out-interface=ether1 log=no log-prefix=""
kdy 10.0.0.136 je vnitřní IP routeru
0 x
http://www.pocasinakladne.cz
http://www.benyhogalerie.cz
2011UiAS-2HnD OS 6.42.6
3011UiAS-RM OS 6.42.6

Beny44
Příspěvky: 54
Registrován: 3 years ago

Příspěvekod Beny44 » 8 months ago

Rozchozeno, použitím statických DNS (které jsem sice měl pro Proxy Web), ale neměl jsem použit DNS server Mikrotik ve win :-(
0 x
http://www.pocasinakladne.cz
http://www.benyhogalerie.cz
2011UiAS-2HnD OS 6.42.6
3011UiAS-RM OS 6.42.6


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 9 hostů