Nastavení Queue Tree

Návody a problémy s konfigurací.
GeniuZ
Příspěvky: 5
Registrován: 9 months ago

Re: Nastavení Queue Tree

Příspěvekod GeniuZ » 9 months ago

Dekuji za odpoved. Ano, tak to mam nastaveno, typ mam PCQ, konkretne tam mam 2 nastaveni PCQ, jedno bez src adresy (vice ip adress v jedne queue na jeden bandwidth) a druhe se src adresou (jedna ip adresa na jednu queue).

image1.PNG
image1.PNG (108.5 KiB) Zobrazeno 930 x

image2.PNG
image2.PNG (65.81 KiB) Zobrazeno 930 x

image3.PNG
image3.PNG (65.21 KiB) Zobrazeno 930 x
0 x

GeniuZ
Příspěvky: 5
Registrován: 9 months ago

Příspěvekod GeniuZ » 9 months ago

Prehledl jsem v odpovedi, ze min limit take na max. Puvodne jsem to mel bez limit-at, max-limit a take to nedelalo spravne. Limit-at ma tedy byt nastaven take na max. hodnotu, aby to rovnomerne balancovalo?
0 x

CrazyApe
Příspěvky: 531
Registrován: 3 years ago

Příspěvekod CrazyApe » 9 months ago

Nastav to jako SFQ a každá ta queue "dn" musí mít svůj mangle rule s chain forward a ip podle down/up vyplněné v src adres/dst adress passthrough nezaskrtle a vybrány in interface (wan nebo lan interface) taky podle toho jestli je to up nebo down smer.
0 x

Uživatelský avatar
midnight_man
Příspěvky: 3625
Registrován: 7 years ago

Příspěvekod midnight_man » 9 months ago

jak nastavujete Limit-at ??? max limit rozumieme...ale ako na limit-at?

čo sa tyka toho PCQ samotného...menite default nastavenia?
0 x

CrazyApe
Příspěvky: 531
Registrován: 3 years ago

Příspěvekod CrazyApe » 9 months ago

Pcq funguje úplně jinak ale. Takdle jak má ten strom je třeba SFQ.
0 x

GeniuZ
Příspěvky: 5
Registrován: 9 months ago

Příspěvekod GeniuZ » 9 months ago

CrazyApe, dekuji za odpoved. A to jsem si nechal nastavit uvodne od firmy, aby to bylo spravne :-(
Ted uz to mam rozpokusovane, protoze to nefungje spravne.
Takze zmenim PCQ na SFQ, mangle tam mam, ale jen dle adresy src/dst, bez interface, a v chainu mam "prerourting".
Nicmene ten router je vyclenen pouze na shaping mezi public IP adresami (Ve firewallu je input, output, forward vse jako "accept".).
Ten mangle tedy musim z "prerouting" zmenit na "forward" a docvakat interfejsy?
0 x

CrazyApe
Příspěvky: 531
Registrován: 3 years ago

Příspěvekod CrazyApe » 9 months ago

Ja nevim, jak to mas presne udelat :-) nevim situaci ani konfiguraci toho routeru. Ja jen rikam, ze kazda IP ktera se ma shapingovat ma mit chain forward, podle smeru vypsany src adress/dst adress a vyplneny in interface bud "WAN"(interface ze ktereho je UPlink) a nebo LAN(interface ze ktereho to jde do vnitrni site) pokud je to vic interfacu tak daný bridge, nema byt zakrizkovany passthrou a action mark packet. Pak je potreba udelat 30M queue s parentem globa pojmenovanou např "konektivita_DOWN" a pak X krat queue s libovolnym jmenem kde je vybrany parent konektvita_DOWN a vybrany daný packetmark pro down smer kde maxlimit je 30M a min limit je (30/X kde X je počet queue) a pak stejn strom pro UP směr. NEvim jak lip to vysvetlit. A tech X queue by melo byt SFQ pokud ten strom ma vypadat tak jak vypada.

PCQ funguje tak, ze mas hlavni konektivitu jeden queue a podnim jednu queue typu PCQ pro X ruznych ip adres(treba /24 blok) ale dokazes to delit vzdycky jen "spravedlive" nikdo nemuze mit víc/mín.


EDIT: a myslim ze to muzes mit (mangly) i pomoci chainu prerouting a postrouting ale zda se mi ze na skoleni mi nekdo rikal ze od ROS v6 prochazi packety jinak jadrem a jeden z tech chainu nebude manglovat ale nejsem si jisty.
0 x

CrazyApe
Příspěvky: 531
Registrován: 3 years ago

Příspěvekod CrazyApe » 9 months ago

/ip firewall mangle
add action=mark-packet chain=forward comment=192.168.3.10 new-packet-mark=ostatni10_UP passthrough=no src-address=192.168.3.10
add action=mark-packet chain=forward dst-address=192.168.3.10 new-packet-mark=ostatni10_DOWN passthrough=no

/queue tree
add max-limit=15M name=DOWN parent=global queue=default
add max-limit=5M name=UP parent=global queue=defaul
add disabled=no limit-at=1M max-limit=15M name=192.168.3.10_DOWN packet-mark=ostatni10_DOWN parent=DOWN queue=deleni
add disabled=no limit-at=1M max-limit=5M name=192.168.3.10_UP packet-mark=ostatni10_UP parent=UP queue=delen

Tady je priklad pro jednu a neni tam vybrany out a in interface (nevim proc to tam nema) asi to jede i bez toho. Queue ktera se jmenuje "deleni" je sfq. Nedelal jsem to ja ale vypada to ze mu to funguje je to od jednoho zakaznika ktery vim ze si to delal podle nejakeho navodu co jsem mu posilal.
0 x

GeniuZ
Příspěvky: 5
Registrován: 9 months ago

Příspěvekod GeniuZ » 9 months ago

Diky za odpoved. Co by melo byt nastaveno jako Queue Type v parent? (uz to vidim v predchozi odpovedi, tedy default, mozna jestli neni problem v tomto, protoze zde jsem mel take PCQ)

Kazda vetev z meho pohledu predstavuje verejnou IP adresu nebo subnet verejnych IP adres. Nechci shapovat spojeni pod temito verejnymi IP adresami, ale chci shapovat jen ty verejne IP adresy mezi sebou (a subnet je v tomto pripade povazovan za jednu adresu, tedy jednu vedev neboli jeden blackbox pro shaping). Kdyby tam nebyl ten subnet, tak by na to asi stacil jeden radek, ale s tim subnetem se v tom ztracim.

A cilem ma byt, aby se mezi sebou shapovali rovnomerne jednotlive vetve, ve vetvich at se nic neshapuje. Idealne tam ani nikde nemit nastaveny zadne limity, to si limituje urcite ISP, takze to mit cele dynamicky a fifty fifty.

Na miktorku pisi, ze "Per Connection Queuing (PCQ) is a similar to SFQ, but it has additional features.", takze v PCQ vs SFQ by asi byt problem nemel.
0 x

ludvik
Příspěvky: 3988
Registrován: 7 years ago

Příspěvekod ludvik » 9 months ago

Queue type v parentech můžeš mít co chceš. Tam totiž nemají žádný smysl. Uplatňují se až na konci, na listech stromu :-)

Ano, PCQ je obdoba SFQ. Obě si dělí provoz do "trubek" do kterých pouští provoz. PCQ je na základě IP. Kdežto SFQ je na základě konexe. Výsledek je ten, že při PCQ si žádná IP neurve vyšší kapacitu jen tím, že použije víc konexí zároveň.
PCQ lze nastavit různě, i na subnety (výchozí stav je /32, čili každá IP samostatně). Ale musí ti to pasovat do masky aby jeden klient nepadal do dvou trubek zároveň.

Pokud máš tedy stromek udělaný tak, že rozděluješ jednotlivé klienty do větví - SFQ ti stačí. Možná je to i lepší, protože trochu lidem vyvážíš provoz (viz dělení trubek na konexe).
Pokud uděláš stromek jednodušeji (čili v podstatě jen rozdělíš input a output markováním), tak je vhodné PCQ a na jednom směru zapnout klasifikaci podle DST-IP a na druhém podle SRC-IP. Tak nějak samo to rozhodí kapacitu pro každou IP rovnoměrně.

Pochopení směru toku paketů do PCQ je docela důležité. Protože co udělá klasifikace podle SRC-IP na klientově downloadu? Každá IP co se na internetu vyskytne bude mít svoji vlastní trubku ... a chudák router. Kromě toho se chování přiblíží SFQ.

A to všechno si můžeš zkombinovat do naprostých šíleností :-)

Nebo se na to všechno vykašlat a zkusit simple queue. To před nějakým časem zoptimalizovali tak, že tam lze mít opravdu šílené množství pravidel, aniž by nějak výrazně rostlo vytížení routeru. Také to má výhodu na víceprocesorech, protože je to paralelizovatelné, na rozdíl od QT.
1 x
Ohledně GDPR již nediskutuji. Když nic nevím, musím si to nastudovat jinde - a pak už to vím a nemám potřebu diskutovat zde.

Rosak
Příspěvky: 175
Registrován: 5 years ago

Příspěvekod Rosak » 9 months ago

Ahoj. Prosím o radu, jak by měla vypadat parent queue v SQ. Chci zkusit nahradit QT, kde je jediná parent queue (mám do firmy konekt half-duplex bezdrátem) a pod ní koncové queue reprezentující jednotlivé IP, jiné pak několik IP a to ze dvou až tří subnetů, pocházející pokaždé z jiného interface toho MK. Ty koncové jsou mi jasné, ale ta parent mi nějak nejde.
0 x

Noxus28
Příspěvky: 334
Registrován: 7 years ago

Příspěvekod Noxus28 » 9 months ago

V SQ by si mal mať na parente hodnotu limit-at=tvoj garantovaný konekt a max-limit=to čo si dovolíš pustiť von na max.
Koncové potom majú hodnotu limit-at=hodnotu ktorú mu minimálne garantuješ (súčet všetkých koncových sa musí rovnať limit-at parentu) a max-limit= koľko chceš aby IP išla max pokiaľ je voľná linka (čiže sťahovanie ostatných nedosiahne limitu parenta)

Podobne to funguje aj keď máš subparenty. Prideľovanie kapacity funguje od spodku:
- naplní sa rýchlosť limit-at koncáka
- skontroluje sa či má subparent voľnú kapacitu max-limit ak áno, o ňu navýši rýchlosť koncáka (ak sa neprekročila max-limit koncáka)
...
- skontroluje sa či má parent voľnú kapacitu max-limit ak áno, o ňu navýši rýchlosť koncáka (ak sa neprekročila max-limit koncáka)

pokiaľ "sťahujú" všetci "koncáci" musí ísť celý strom na hodnote limit-at. ináč sa to nespráva korektne a nefunguje ako má.
Ešte sa do toho môžu pliesť bursty, priority a podobne ale zjednodušene by to malo fungovať takto (ak som niečo nepozabúdal z MTCNA)
simpleQ.png
simpleQ.png (92.75 KiB) Zobrazeno 535 x
1 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓

Rosak
Příspěvky: 175
Registrován: 5 years ago

Příspěvekod Rosak » 9 months ago

Omlouvám se, jsem pitomec a špatně jsem to specifikoval. Tohle co píšeš je mi jasné z QT, které již léta používám, ale i tak díky za shrnutí. To co nevím je, jak nastavit "target" té parent queue, když jsou koncové queue z různých subnetů a různých interfaců tohohle MK.
0 x

Noxus28
Příspěvky: 334
Registrován: 7 years ago

Příspěvekod Noxus28 » 9 months ago

použitie 0.0.0.0/0 by nepomohlo? a dst: wan interface
0 x
MTCNA, MTCRE, MTCTCE a furt toho viem málo 🤓

Rosak
Příspěvky: 175
Registrován: 5 years ago

Příspěvekod Rosak » 9 months ago

Jo, to je ono, díky. Zkoušel jsem to s tím 0.0.0.0/0, ale neměl jsem vyplněnou položku DST. Proto mi to veškerý trafik v té queue zobrazovalo jako download.
Takže když mám konekt něco málo přes 20M přes WIFI, nastavím max-limit pro oba směry na 20M a stejně tak i max-limit 20M i záložce "total", je to tak?
0 x


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 9 hostů