crs328‑24 nastavení VLAN

Návody a problémy s konfigurací.
the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

crs328‑24 nastavení VLAN

Příspěvekod the.max » 1 week ago

Tak po téměř čtyřech měsících se nám vrátil CRS328‑24P‑4S+RM z reklamace výměnou za nový kus. Rád bych se vyvaroval nemilému překvapení, kdy mi na sajtu po dvou minutách provozu totálně zkolaboval kvůli konfiguraci HW VLAN, následnému resetu do defaultu a konfiguraci VLAN softwarových, chtěl bych poprosit, jestli by sem někdo nepastnul kus vyexportované zálohy týkající se konfigurace HW VLAN.

Předem děkuji.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.

Uživatelský avatar
hapi
Příspěvky: 11573
Registrován: 11 years ago
Kontaktovat uživatele:

Příspěvekod hapi » 1 week ago

nech to naject do swos a funguje s vlany. Konfigurace hw vlanů sice je možná v mikrotiku ale je to naprosto šílený a je to na wiki.
0 x

S_a_M
Příspěvky: 158
Registrován: 3 years ago
Bydliště: Protektorat Böhmen und Mähren

Příspěvekod S_a_M » 1 week ago

No to si myslim ze prave nechce ponevadz do swos se po chybe nedostane a na saitu o kterem se bavime je docela na prd pristup, administrativne.
0 x
Proste trollim :D

the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

Příspěvekod the.max » 1 week ago

VLANy v SwOSu jjsou krajní řešení. Je to právě kvůli tomu, že jak při konfiguraci udělám chybu a odříznu se, tak mi nezbyde nic jiného než reset do defaultu a nová konfigurace. I když, tohle narozdíl od RB260 má konzoli, ale jestli v SwOSu funguje zatím nevím
Nastavovat HW VLANy je na mikrotiku porod, o tom žádná. Kdyby se to alespoň na všech nastavovalo stejně, ale co co řada, to jinej postup. Tohle by mohli chlapci také sjednotit.
Podle Wiki jsem je nastavvoal před těmi čtyřmi měsíci, na stole mi to všechno krásně fungovalo, ale jak jsem to dal na site, do dvou minut bylo po srandě. CRS125 mi funguje v pohodě, také podle Wiki, ale tohle prostě padlo na držku. Tak než to budu podstupovat znovu, raději bych viděl opravdu fungující konfiguraci, protože je možné, že jsem při tom někde udělal chybu.

Asi by mi stačil jednoduchý příklad, kdy mám dejme tomu 4 VLANy, 10,100,200,300, přičemž 10 je pro management. Tagovanej uplink je na SFP1, na portech ether1 a ether2 vylejzaj dál VLANy 10 a 100, na ether4 a ether5 jdou dál tagované 10 a 200. A na portech ether6 a ether7 mam už netagovanou 300 a na ether8 netagovanou 10.

Ono toho tam bude ve finále víc, ale tohle mi stačí pro nakopnutí správným směrem.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.

Petr Bačina
Příspěvky: 985
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 week ago

0 x

dagus
Příspěvky: 1075
Registrován: 7 years ago

Příspěvekod dagus » 1 week ago

Viděl jsem nějaký video z mum a tvářil se, že řada crs 3xx má nové nastavení vlan. Moc jsem to nevnímal, když mi to na pozadí běželo, ale něco takového tam vysvětloval. To okounovo video je ok, ale bude fungovat i teď kde už master slave nie?
0 x

the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

Příspěvekod the.max » 1 week ago

Jako VLANy mi skrz switch procházej. Umím odtagovat vybraný provoz a pustit to portem nebo několika porty ven. Netagovaný provoz se mi otaguje a odchází ze switche. Až pocamcaď je to cajk.

Ale nejsem schopnej podle WiKi nastavit IP pro management. Na WiKi je, že mám na bridge1 přidat softwarovou VLANu s daným PVID a následně jí přiřadit IPčko. To projde, ale na switch se odnikud nedostanu a nikde tu jeho IP nevidím.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.

iTomB
Příspěvky: 753
Registrován: 12 years ago

Příspěvekod iTomB » 1 week ago

the.max píše:Jako VLANy mi skrz switch procházej. Umím odtagovat vybraný provoz a pustit to portem nebo několika porty ven. Netagovaný provoz se mi otaguje a odchází ze switche. Až pocamcaď je to cajk.

Ale nejsem schopnej podle WiKi nastavit IP pro management. Na WiKi je, že mám na bridge1 přidat softwarovou VLANu s daným PVID a následně jí přiřadit IPčko. To projde, ale na switch se odnikud nedostanu a nikde tu jeho IP nevidím.

No a to musis oddelegovat na uplinkportu jako tagovane, nekde na druhe strane tu samou VLANu s IP a nastavit GW.
0 x

Petr Bačina
Příspěvky: 985
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 week ago

vytvoříš VLANu na "přívodním" trunku, na tu si dáš IP adresu a ve "switch VLAN -> Eg. VLAN Tag" dáš kde má být tagovaná a zároveň tam musíš mít switch1-cpu aby ti to šlo

Příklad: VLANY 22,632,640,641 jsou tagované na eth1,2,3 a VLAN22 je management.
Přílohy
vlan22.JPG
vlan22.JPG (50.89 KiB) Zobrazeno 330 x
0 x

the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

Příspěvekod the.max » 1 week ago

Dík, takhle to mám nastaveno na CRS112, ale na 3xx se VLANy nastavují jinak, co jsem pochopil z dokumentace, tak vše se řeší na bridgi a tam chybí "port" switch 1-cpu.

Aktuálně mám toto:

Kód: Vybrat vše

/interface bridge
add name=bridge1
/interface vlan
add interface=bridge1 name=MGMT vlan-id=68
/interface bridge port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether17
add bridge=bridge1 interface=ether18
add bridge=bridge1 interface=ether19
add bridge=bridge1 interface=ether20
/interface bridge vlan
add bridge=bridge1 tagged=ether3,ether4,ether5,ether9 untagged=ether2 vlan-ids=68
add bridge=bridge1 tagged=ether3,ether4 vlan-ids=101
add bridge=bridge1 tagged=ether3,ether5 vlan-ids=102
add bridge=bridge1 tagged=ether3,ether9 untagged=ether17,ether18,ether19,ether20 vlan-ids=104
/ip address
add address=100.64.0.200/24 interface=MGMT network=100.64.0.0


Pokud ale zapnu

Kód: Vybrat vše

/interface bridge add name=bridge1 vlan-filtering=yes
tak už si switch nepingnu.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.

Petr Bačina
Příspěvky: 985
Registrován: 4 years ago
Bydliště: Horní Slavkov
Kontaktovat uživatele:

Příspěvekod Petr Bačina » 1 week ago

Aha, tak to se omlouvám za dezinformaci. Nějak jsem nepředpokládal, že by to mikrotik řešil na CRS328 jinak než na CRS112.

Tohle je z tik fóra

Kód: Vybrat vše

Each vlan represent a brXX interface,
Each trunk port need to add vlan interfaces: ethX.XX
One logical trunk interface needed, add every trunk interface here: br0
Add each trunk interface's vlan interface to the brXX to have access: br10,br20

# reset switch config
$> /system reset skip-backup=yes no-defaults=yes

# br0 will be the trunk bridge
$> /interface bridge add comment=TRUNK name=br0 protocol-mode=none vlan-filtering=yes

# br10 will be the vlan10 bridge
$> /interface bridge add comment=VLAN10 name=br10 pvid=10 vlan-filtering=yes

# br20 will be the vlan20 bridge
$> /interface bridge add comment=VLAN20 name=br20 pvid=20 vlan-filtering=yes

# add vlan interface for eth1:  vlan10 tagged + vlan20 tagged: eth1.10, eth1.20
$> /interface vlan add interface=eth1 name=eth1-vlan10 vlanid=10
$> /interface vlan add interface=eth1 name=eth1-vlan20 vlanid=20

# assign eth1 to br0
$> /interface bridge port add bridge=br0 frames-type=admit-only-vlan-tagged interface=eth1

# assign eth1.10 to br10: VLAN10 managment
$> /interface bridge port add bridge=br10 frames-type=admit-only-untagged-and-priority-tagged interface=eth1-vlan10

# assign eth1.20 and (eth2 to eth24) to br20: VLAN20 PCs:
$> /interface bridge port add bridge=br20 frames-type=admit-only-untagged-and-priority-tagged interface=eth1-vlan20
$> /interface bridge port add bridge=br20 frames-type=admit-only-untagged-and-priority-tagged interface=eth2
...
$> /interface bridge port add bridge=br20 frames-type=admit-only-untagged-and-priority-tagged interface=eth24

# add management ip-address - as you want: VLAN10
$> /ip address add address=192.168.10.10/24 interface=br10 network=192.168.10.0

Thats all.
0 x

the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

Příspěvekod the.max » 1 week ago

jj, tohle jsem už taky procházel, ale přišlo mi to takový docela zmatečný. Našel jsem prezentaci https://www.youtube.com/watch?v=IEE_dszZGLc kde zhruba od 18. minuty řeší právě CRS328, ale s tou angličtinou mám trochu problém. Slajdy k prezentaci jsou tady: https://mum.mikrotik.com/presentations/ ... 295658.pdf

Já taky nechápu PROČ na různých řadách mikrotiků se VLANy řeší vždy jinak. Pochopil bych, že někde jsou použitý switche co VLANy neumí, někde ani ty switche nejsou (tak by se ale prostě VLANy nastavili softwarově). Ale když už je board se switchem, kterej VLANy umí, PROČ to ve winboxu nejde naklikat stejně, když třeba na SwOSu to jde byť jsou tam taky drobounké rozdíly. Nebo kdyby alespoň třeba byla možnost, jak si switch naklikat v tom SwOSu a pak si do ROSu přetáhnout konfiguraci.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.

the.max
Příspěvky: 1102
Registrován: 11 years ago
Bydliště: Sudetten land
Kontaktovat uživatele:

Příspěvekod the.max » 6 days ago

HURÁÁÁÁÁÁÁÁ už jsem na to přišel.
Narazil jsem na tento slajd, kde je to popsáno. Postup je v podstatě stejný, jako je na WiKi Mikrotiku, ale je tam jedna dost podstatná věc, na kterou jsem nikde jinde nearazil. Pokud chci např. mít management switche ve VLANě 20, tak musím v přidat v jejim nastavení bridge (ve kterém jsou jednotlivé porty) mezi untagged porty. A to je věc, kterou jsem nikde neviděl, nebo si jí prostě nevšiml.
0 x
Vysoce odborných omylů se dopouští jen specialisté.

Jednou jsem se dotkl ukazováčkem UBNT a slezl mi z něho nehet. Od té doby na UBNT nesahám.


Zpět na „Konfigurace“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 10 hostů