60G zálohování +hystereze ?

WIFI, LTE, dvoubodové spoje, antény atd. Vlákna zaměřené přímo na problematiku MikroTik/RouterBoard a Ubiquiti prosím směrujte do příslušného fóra, viz výše.
pgb
Příspěvky: 541
Registrován: 2 years ago

60G zálohování +hystereze ?

Příspěvekod pgb » 4 months ago

Ahoj,
pokud to nemáte jako svoje interní tajemství, jak řešíte zálohování na 60G pro chvíle výpadků? Zatím to trénuji na stole a s žádným řešením nejsem úplně spokojený. Mým cílem je 60G hlavní + backup na 5G s hysterezí ve chvíli kdy hlavní spoj padá (z důvodu deště) a v krátkých chvílích se rozpojuje a spojuje(EDIT:špatný popis, nerozpojí se, ale ztrátuje) (aby se pořád nevracel backup na hlavní a znovu a znovu) ...... možná řešení technického problému:
RSTP:
- cca 6s výpadek max
- nemá hysterezi
+ jednoduché na konfiguraci
OSPF + bfd:
- pro transparetní spoj vyžaduje nasadit nad tím mpls+vpls, složité na konfguraci, vlana pro druhý spoj
- nemá hysterezi
+ výpadek cca 2s
OSPF'+ custom script
- pro transparetní spoj vyžaduje nasadit nad tím mpls+vpls, složité na konfguraci, vlana pro druhý spoj
- vyžaduje dobře napsaný skript pro detekci chybovosti spoje (u mk jak známo nemusí v budoucích verzích fungovat, nutnost údržby)
+ výpadek cca 2s
+ lze naprogramovat hysterezi pro návrat

Používáte něco jiného co mě nenapadlo?

EDIT: Funkční skript na hysterezi jsem postnul níže.
Naposledy upravil(a) pgb dne 28 Oct 2018 13:19, celkem upraveno 2 x.
0 x

cerva
Příspěvky: 234
Registrován: 4 years ago

Příspěvekod cerva » 4 months ago

Nabízí se ještě varianta známá z profispojů - "port down on link down" - hysterezi řídí scriptem samotná wAPka, která jako jediná má přehled o stavu radiové trasy. Nad tím už jakýkoli protokol s rozumnými timery. Mám v plánu něco takového brzo vyzkoušet, mordor se už blíží :D
0 x

pgb
Příspěvky: 541
Registrován: 2 years ago

Příspěvekod pgb » 4 months ago

Ok, to je trochu jiný přístup nežli kontrolovat nedostupnost protistrany pomocí icmp. Reálně znám totiž třeba na mimose i ubnt spoustu stavů, kdy linka ztátuje, ale link down není (u profi spojů je to jiné proti wifi). U 60G je to podobné, vyzkoušet se to dá lehce - dáš ruku před zářič, link down není, ale spoj ztrátuje. Touhle cestou nepůjdu. Hysterezi mi řeší skript na samotném 60G radiu.

Ta moje třetí varianta:
Zapojení vypadá tak, že jsou spojené dvě 60G a routují. Pak mají mezi sebou ještě přes lan port propojku přes vlanu a přes jiný spoj, zase routují. Celé to řídí ospf jen mezi dvěmi 60G, nad tím celém stojí mpls/vpls aby to ve finále dalo transparentní propoj. Problém je s tím skriptem (napsal jsem ho, fungje to dobře), ale raději bych použil něco standartizovaného.
0 x

Uživatelský avatar
okoun
Příspěvky: 6133
Registrován: 9 years ago
antispam: Ano
Bydliště: Mordor

Příspěvekod okoun » 4 months ago

no koukám že u mikrotiku to zase nedodělali u BFD

Kód: Vybrat vše

Features not yet supported

echo function
on-demand
mode    authentication
0 x
Povoláním ISP není jen připojovat lidi k internetu, ale také jim dokázat vysvětlit, že bez pořádné investice do HW nelze udělat kvalitní přípojku a domácí síť...

cerva
Příspěvky: 234
Registrován: 4 years ago

Příspěvekod cerva » 4 months ago

pgb píše:Ok, to je trochu jiný přístup nežli kontrolovat nedostupnost protistrany pomocí icmp. Reálně znám totiž třeba na mimose i ubnt spoustu stavů, kdy linka ztátuje, ale link down není (u profi spojů je to jiné proti wifi). U 60G je to podobné, vyzkoušet se to dá lehce - dáš ruku před zářič, link down není, ale spoj ztrátuje. Touhle cestou nepůjdu. Hysterezi mi řeší skript na samotném 60G radiu.

Ta moje třetí varianta:
Zapojení vypadá tak, že jsou spojené dvě 60G a routují. Pak mají mezi sebou ještě přes lan port propojku přes vlanu a přes jiný spoj, zase routují. Celé to řídí ospf jen mezi dvěmi 60G, nad tím celém stojí mpls/vpls aby to ve finále dalo transparentní propoj. Problém je s tím skriptem (napsal jsem ho, fungje to dobře), ale raději bych použil něco standartizovaného.


Jasně, operation down status na wlan je až poslední fáze rozpadnutí (u profispojů ostatně taky, bereme-li v úvahu ACM, proto taky existuje standard na předávání informace o modulační rychlosti na nejbližší switch/router, který podle toho může balancovat trasy). Na wifině by šla klidně hlídat modulace, na 60 GHz signál nebo použít ICMP. Zásadní mi přijde rychlost předání informace o nedostupnosti a potom ta hystereze. Když shodím port, je reakce prvku na druhé straně okamžitá i v případě OSPF, RSTP. A wAPka pak bude koukat na signál, pingat a když minutu dobrý, tak port zapne. Zatím je to jen vize, skusím to napsat a otestovat.

Tvé řešení vypadá hezky (rychlost předání si řeší interně wAPka, hysterezi script), jen by mi úplně nevyhovovalo z hlediska topologie - při pádu jedné linky posílám provoz často jinudy, ne paralelním záložním spojem na stejný bod.
0 x

pgb
Příspěvky: 541
Registrován: 2 years ago

Příspěvekod pgb » 4 months ago

Pokud to posíláš jinudy, tak to situaci samozřejmě trohu komplikuje. Ano ... (jen pro vysvětlení pro ostatní - neshazuji port fyzicky), pouze v interfacu ospf, jinak by skrz něj nešlo dělat kontrolu jak to vypadá. Dokončil jsem ten skript na paralelní trasu. Není to žádná krása, ale funguje to dobře, někomu to třeba bude sloužit pro inspiraci. Nepouští se to každou minutu, ale pouze jednou po startu - běží to v cyklu a funguje to kvalitně. Posílá icmp na cílový host a pokud detekuje výpadek, tak ten port v ospf na 30s vyřadí, pak zkusí znovu icmp a pokud po 30s projde tak ho povolí.Takhle to pošle jedno icmp za sekundu, díky shození ospf interfac u se to za 2s překlopí celé.

edit: ten skript s hysterezí ti bude takhle fungovat i ve tvém setupu, když data posíláš zálohou jinudy. Stačí ho nasadit na správném zařízení

Skript na hysterezi:

Kód: Vybrat vše

:local DSTIP "10.255.255.2"
:local INTERFACE "ether4-wifi60G"
:local timer 0
:local pause false
:global hystereze start

while ($hystereze != "stop") do={
  if ($timer = 0) do={
    if ([/ping $DSTIP count=1] = 0) do={
      if ($pause = false) do={
        :set timer 30
        :set pause true
        :log info "60G backup activated"
        /routing ospf interface set [find where interface=$INTERFACE] passive=yes
      }
    } else={
      if ($pause = true) do={
        :set pause false
        /routing ospf interface set [find where interface=$INTERFACE] passive=no
        :log info "60G restored"
      }
    }
  }
  if ($timer > 0) do={:set timer ($timer-1)}
  delay 1
}


edit: skrip upraven, vypnout se dá pomocí příkazu v konzoli

Kód: Vybrat vše

:set hystereze stop
0 x

pedro4444
Příspěvky: 748
Registrován: 8 years ago

Příspěvekod pedro4444 » 4 months ago

ja to mam poriesene cez skripty.... ako nahle sa strati 20 pingov prehodi na backup a je jedno ze po 20 pingov to uz ide pokial to nepojde 100 pingov bez vypadku dva krat po sebe v 5 minutovych intervaloch neprepne spat....

a po tych 10 minutach yz vzdy dazd ustali a ak sa nestratit ani jeden ping tak to v klude prepne na 60...
1 x


Zpět na „Wireless“

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 8 hostů